Heater blower

Tiny
MDENNIS7168
  • FORD ESCORT

2000 Ford Escort. Heater blower stopped working - stopped to go to ATM, came back & did not work. Tested circuit breaker for continuity -OK. Swiched circuit breaker with same size one for power windows - no effect (do not have power windows). Pulled blower & tested with battery - OK. Removed switch -inspected - looks OK. Is there a relay somewhere that the ignition switch enables to send power to the circuit? That is the only thing I have not been able to find / trace. :Roll:

Do you
have the same problem?
Yes
No
Monday, August 6th, 2007 AT 8:26 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER

You are probably looking for the resistor pack-let me know if you cannot find it and i'll go look for it for the mean time


http://www.2carpros.com/forum/automotive_pictures/12900_baby_smoking_3.gif

I'll be taking a break see you later

Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2007 AT 3:52 AM
Tiny
RASMATAZ
  • MEMBER

I've finished my puffing-I believe that the resistor pack is behind right side of the dash in the AC-Heater plenum.


http://www.2carpros.com/forum/automotive_pictures/12900_baby_smoking_4.gif

I'll be on break again

Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2007 AT 4:00 AM
Tiny
MDENNIS7168
  • MEMBER

I did pull the resistor pack & checked continuity across that as well & found no issues there either. So I am still stumped.

Thanks for your prompt reply.

Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2007 AT 6:40 PM

Please login or register to post a reply.

Other Blower Fan Not Working Questions