Fuel pump and filter

Tiny
HEAVENLYROSE33
  • MEMBER
  • FORD ESCORT
I have a 1990 ford escort lx 1.9L 4 cylinder. I need to know if you guys might have a diagram on where the fuel pump is and where the fuel filter is. The car isn't getting any gas. We used starter fluid and it will start and die. Please help if you are able? Thank you.
Do you
have the same problem?
Yes
No
Tuesday, February 20th, 2007 AT 3:20 PM

6 Replies

Tiny
MALLETSLINGER
  • MEMBER
When you turn the ignition key to the on position, can you hear the fuel pump engage?
Was this
answer
helpful?
Yes
No
Tuesday, February 20th, 2007 AT 4:05 PM
Tiny
MALLETSLINGER
  • MEMBER
I checked the component locator at the autozone website for you.

On your 1990 Ford Escort, the Component Locations - Fuel Filter is:
Under hood, passenger side, upper firewall, near strut tower, mounted in fuel line
Was this
answer
helpful?
Yes
No
Tuesday, February 20th, 2007 AT 4:17 PM
Tiny
HEAVENLYROSE33
  • MEMBER
I am not sure what the fuel pump is suppose to sound like. We did change the fuel filter and it still doesn't work. It will start and die just the way it did before.
Was this
answer
helpful?
Yes
No
+1
Tuesday, February 20th, 2007 AT 9:52 PM
Tiny
MALLETSLINGER
  • MEMBER
Was the old filter plugged up or was it ok? Try blowing through it if you still have it.

When you turn your key to on, the fuel pump primes the engine so that it has fuel when you try to start it. It would probably sound like a quiet humm possibly followed by a tap when the pump kicks off. It is very quite so when you listen for it, everything around you needs to be quiet. You may have a better chance of hearing it if your driver door is open.

Can you tell me what problems you were having before your car refused to start? Any symptoms, noises, or problems you were having while your car still ran could help us understand why it wont start now.
Was this
answer
helpful?
Yes
No
Tuesday, February 20th, 2007 AT 11:07 PM
Tiny
HEAVENLYROSE33
  • MEMBER
My mom said that when she went to start it, it clicked and everything shut off. That happened twice in a row. The lights and everything went off. Then it would just make the regular sound as if it wanted to start. About a week before that it did the same thing and I was able to jump start it. She had to pump the gas, but it did start with help of pumping the gas pedal. We checked the alternator and it was fine. I tried to jump start it and it just made the regular noises as if it wanted to start. When my husband blew into the filter on both sides gas came out and then there was was some crud that came out after that. Hopefully this info helps. Thank you all for your help in this. It is greatly appreciated.
Was this
answer
helpful?
Yes
No
Wednesday, February 21st, 2007 AT 7:22 AM
Tiny
MALLETSLINGER
  • MEMBER
You are making it sound like your battery wont start because the battery is low on charge. Is that what you are trying to say?
If so, have the battery tested, and if its good, then the alternator is probably bad. Alternators don't usually die all at once. They die slowly and towards the end, they will work intermittently.

If Im not understanding what you are trying to say, then please try to explain it again.

As for the gunk that was in the fuel filter, Id add a fuel system cleaner to your next tank of gas.
Was this
answer
helpful?
Yes
No
Thursday, February 22nd, 2007 AT 3:21 AM

Please login or register to post a reply.

Recommended Guides