1993 Ford Bronco Speedometer stopped working

Tiny
I HATE DON
  • MEMBER
  • 1993 FORD BRONCO
  • V8
  • 4WD
  • AUTOMATIC
  • 140,000 MILES
My speedo was shaking and acting like a cable was fraid causing the speedo needle to jump. Now the speedo does not work at all and the truck is not shifting properly. But after looking I have no cable at the back of the speedometer. Where do I need to begin looking to fix this problem? Also my ABS lite has been coming on and off, now on more than off !
Is it electrical or mechanical and where do I need to look for repair? This is on a Eddie Baur Edition.
Can you help me or give me direction?
Do you
have the same problem?
Yes
No
Monday, December 28th, 2009 AT 8:35 PM

3 Replies

Tiny
BLUELIGHTNIN6
  • EXPERT
Hello and thanks for the donation!

Does your odometer operate good?
These symptoms all point to a faulty speed sensor, since this is what is used to operate the speedometer and also sends signals for use of the transmission. The speed sensor is located on the rear axle.
Was this
answer
helpful?
Yes
No
Tuesday, December 29th, 2009 AT 1:34 AM
Tiny
I HATE DON
  • MEMBER
Thanks for the response, at least now I have a direction to look towards. The odometer is digital and stopped working when the speedometer did, the speedometer is a needle type. Is the speed sensor on the rear axle a job I can do myself? Where on the axle will I find it? Will I need to re-calibrate the speedometer when I change out the sensor? Could this be causing the intermittant on and off of the ABS light?
Was this
answer
helpful?
Yes
No
Tuesday, December 29th, 2009 AT 8:54 AM
Tiny
BLUELIGHTNIN6
  • EXPERT


https://www.2carpros.com/forum/automotive_pictures/261618_Noname_1357.jpg

Was this
answer
helpful?
Yes
No
+1
Tuesday, December 29th, 2009 AT 2:56 PM

Please login or register to post a reply.

Sponsored links