1990 Ford Bronco Engine Idle

Tiny
KSCHIRMAN
  • MEMBER
  • 1990 FORD BRONCO
  • V8
  • 4WD
  • AUTOMATIC
  • 300,000 MILES
I have a 1990 Ford Bronco with a 5.0L V8 engine & automatic transmission. The vehicle idle's at a very high rpm while in park or neutral. When placed into drive or reverse, the idle drops some.

I have already replaced the IAC valve & map sensor and traced all of the vacuum lines. I have also ran tests to see if the air intake manifold is leaking and everyhitng looks to be mounted correctly.

Any idea's where to go next? Thanks for the help.
Saturday, April 17th, 2010 AT 5:00 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,837 POSTS
Did you try spraying carb cleaner or starting fluid on the intake or vacuum lines?

Let me know.
Was this
answer
helpful?
Yes
No
Tuesday, April 20th, 2010 AT 10:18 AM
Tiny
KSCHIRMAN
  • MEMBER
  • 2 POSTS
Yeah I sprayed carb cleaner everywhere, around the intake, over the vacuum lines, around the canisters, everywhere, nothing changed.

I have pulled the following DTC codes:
KOEO:
Active - 23, 23 (TPS)
History - 11, 11 (Pass)

KOER:
12, 23, 45, 13, 73, 12, 23, 45, 13, 73

Before my first post I had replaced the IAC and MAP due to previous codes. I have ran the voltage tests on the TPS and it appears to be bad, so i'm going to purchase a TPS sensor.

Any thoughts with the KOER codes?

Thanks.
Was this
answer
helpful?
Yes
No
Tuesday, April 20th, 2010 AT 10:51 AM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,837 POSTS
I question if the tps is going to clear those codes. Replace it and let me know what happens.
Was this
answer
helpful?
Yes
No
Tuesday, April 20th, 2010 AT 11:22 AM

Please login or register to post a reply.

Sponsored links