1988 Ford Bronco

Tiny
DRAGONBRONCO88
  • MEMBER
  • 1988 FORD BRONCO
  • V8
  • 4WD
  • AUTOMATIC
  • 130,000 MILES
My 1988 4x4 Bronco 5.0 V8 truck is possessed. It's not idling correctly very erratic. It's bucking, shutting down starting up (while driving) stalling, and we just put a new IAC on today and no change.

The trans (AOD) is skipping over 3rd gear (new rebuilt) with a hesitation lag, then a rushing sound, then glugging into 4th. It's also revving it's self when I'm trying to stop, or on idle. Would holy water help, or could this be figured out. I have 16,000 into this beast. Maybe I should see a shrink while I'm at it. Lol Help!
Do you
have the same problem?
Yes
No
Friday, September 24th, 2010 AT 8:40 PM

6 Replies

Tiny
MERLIN2021
  • EXPERT
After you installed the new IAC did you clear the codes? If not read the codes write them down, and then remove the negative battery cable for 5 minutes, this will clear the keep alive memory, because of the KAM, the truck may not know it's fixed until memory is cleared. Post codes here. If you need info on reading codes let me know.
Was this
answer
helpful?
Yes
No
Friday, September 24th, 2010 AT 8:45 PM
Tiny
DRAGONBRONCO88
  • MEMBER
Working on it today, will confirm that, the TPS @ 95v, EGR Valve, and also checking for any vacuum leaks.

I'll report back later. Thanks again


http://www.2carpros.com/forum/automotive_pictures/576489_RevHPD_1.jpg

Was this
answer
helpful?
Yes
No
Saturday, September 25th, 2010 AT 9:07 AM
Tiny
DRAGONBRONCO88
  • MEMBER
TPS and EGR Valve. No good. Codes 84, 23, we cleared codes 53, 33, and 63. More tomorrow.

Thanks:)
Was this
answer
helpful?
Yes
No
Tuesday, September 28th, 2010 AT 6:17 PM
Tiny
MERLIN2021
  • EXPERT
Don't forget the ground wire by the battery, clean it up!
Was this
answer
helpful?
Yes
No
Tuesday, September 28th, 2010 AT 10:05 PM
Tiny
DRAGONBRONCO88
  • MEMBER
The trans is (AOD) rebuilt, someone broke the bell housing, (can't get a straight answer, how or why) it has a slight leak from 2 seals, and it's skipping over 3rd gear.

It makes a back rushing sound, (causing an abrupt hesitation during acceleration), then glugs into 4th gear.

Several people told me it may be a matter of an adjustment, by dropping the pan. I can't get it to the trans shop, until the EGR & TPS is installed. By the end of the week/next week It should get to the trans shop.

I'm hoping they're not going to tell me the trans is shot.
Was this
answer
helpful?
Yes
No
Wednesday, September 29th, 2010 AT 9:44 AM
Tiny
MERLIN2021
  • EXPERT
Broken bell housing and leaks are not good, prepare for the worst.
Was this
answer
helpful?
Yes
No
Wednesday, September 29th, 2010 AT 9:54 AM

Please login or register to post a reply.

Recommended Guides