Emission drive cycles reset when truck is shut off

Tiny
HONDABIKEZ
  • MEMBER
  • 2009 CHEVROLET SILVERADO
  • 5.3L
  • V8
  • 4WD
  • AUTOMATIC
  • 218,000 MILES
I have a 1500 I bought it approximately two weeks ago. I have put around 500 miles on it and 4 emission cycles are still incomplete the catalyst system has said ready after driving around 40 miles in one trip. But then when I shut the truck off take the key out and let it sit until the next day. I checked it again and it is back to being not ready along with the other 3 cycles that are not ready the other 3 are o2 sensor, heated o2, and evap. My key cylinder is tricky too to get the key to turn I have to jiggle the key quite a bit to be able to start it is there a possibility that the ignition is to blame or is there some other issue possibly wrong its as if when I shut the truck off it acts as if I am disconnecting the battery but everything else works truck runs just fine shifts good etc. Any help or advice would be appreciated
Thank you
Do you
have the same problem?
Yes
No
Monday, May 13th, 2019 AT 7:39 PM

2 Replies

Tiny
HONDABIKEZ
  • MEMBER
Also, I have checked all the fuses in the fuse box under the hood and drivers side interior fuse panel. All the fuses were good none of them were blown I cleaned all the connections and applied dielectric grease to the fuse box connections. I did that aprox 250 miles ago.
Thanks
Was this
answer
helpful?
Yes
No
Monday, May 13th, 2019 AT 7:59 PM
Tiny
SCWICKEDSTANG
  • EXPERT
Hello,

I have included for you in the diagrams down below factory instructions on how to test your vehicle's Inspection/Maintenance (I/M) Complete System Set Procedures. Please go through them and get back to us with what you are able to find out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Monday, May 13th, 2019 AT 9:40 PM

Please login or register to post a reply.

Recommended Guides