Electrical failure

Tiny
428CJGT500
  • MEMBER
  • 2004 FORD MUSTANG
  • 3.9L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 150,000 MILES
Brake lights failed 3rd brake lite work's turn signals works
Do you
have the same problem?
Yes
No
Wednesday, December 11th, 2019 AT 8:47 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Since the third brake light is working, either you have an issue with splice 323 or there is an issue in the multi function switch. It won't be a ground issue since everything other works.

Take a look at pic 1. I indicated power flow with red arrows. Power from the switch is directed through fuse 41. From there it goes two directions via the splice I mentioned and is circled in the pic. One direction is the third brake light (which works) and the other is to the multi function switch which then directs it to the brake lights / signals.

So, we know we have power at the splice above to the 3rd BL, but not to the multi function switch. Start there. Probe the dark green wire on the rear of the multi function switch. If it doesn't have power when the brakes are applied, suspect the splice has failed. If it does have power, then I need you to check orange/light blue wire and the light green/orange wire out of the switch. They should have power when the brakes are applied. If there is no power there, but power does enter the switch, replace the switch. If there is power out and the lights don't work, then at some point there is a break in the wiring. However, since they both don't work, I suspect a problem at the splice or the switch.

The second pic below shows power coming from the switch to the rear brake lights.

I noted you are certified, so I assume you have a digital multi meter or a test light. Let me know if you have questions or need anything.

Also, if you could, let me know what you find.
Take care,

Joe
Was this
answer
helpful?
Yes
No
Wednesday, December 18th, 2019 AT 8:14 PM

Please login or register to post a reply.

Sponsored links