95 TSI AWD AUTOMATIC PERFORMANCE PROBLEM

1995 Eagle Talon

Tiny

jashika

September, 18, 2007 AT 5:52 PM

Hi everyone!
I have a 95 Eagle Talon tsi AWD automatic 84k miles on it. I bought it with rod knock. I replaced the main and rod bearings and resurfaced the crankshaft and the rods. I didn't buy new pistons or rings because the compression was 155-160 psi. Everything seems fine with the engine now. The problem is that the car seems that it has not much power. Turbo screams so I guess that's all right. Check engine light is not on. If I put it in to drive or reverse it just stalls (most of the time but not every time) if I don't give some gas. The idle is about 800rpm so I think that's ok. I did a " torque converter stall speed test" on it and it was 2900 rpm, which is low because it needs to be between 3300-3800. Which means engine performance is poor or defective torque converter. I guess it's rather the engine or I don't know.
Does anyone have any idea? The problem is that I ran out of money totally getting this car together so I can't take it to a shop.
Thank you!
Peter

FOUND 16216 RELATED QUESTIONS

2 Answers

Tiny

digitalrain

October, 21, 2007 AT 5:50 AM

Sounds like you have a boost leak, Go over every fitting from the air filter to the manifold.

Tiny

jashika

October, 31, 2007 AT 8:34 PM

I'm pretty sure that all the hoses are good. I took apart every piece and checked them, I did't find any defects, leaking. Thank you anyways!

Peter

Please login or register to post a reply.

Find Out How to Test Your Catalytic Converter
Catalytic Converter Replacement Volkswagen
Fuel Filter Replacement Chevrolet Silverado
Fuel Filter Replacement Chevrolet Silverado