NEW ALTERNATOR NOT WORKING

1991 Eagle Summit

Tiny

Ramza666

December, 3, 2008 AT 3:31 PM

Electrical problem
1991 Eagle Summit 4 cyl Front Wheel Drive Automatic 140000 miles

just bought a new alternator, had a little trouble attaching the metal band to the post on the alternator cause it was in a slightly different location.
however I got it installed, with all the plugs on and when I jump the car, it dies in 10 minutes, or less if I turn on the lights. I am at a loss

FOUND 1921 RELATED QUESTIONS

Why Is My Battery Light On?

35 ANSWERS
1 IMAGE

Gen Light

28 ANSWERS

5 Answers

Tiny

mhpautos

December, 3, 2008 AT 3:34 PM

HI there,

With the engine running, check the Voltage at the main alternator terminal, check it with the car at around 1500 RPM, report back the reading for more advice.

Mark (mhpautos)

Tiny

Ramza666

December, 3, 2008 AT 3:36 PM

Which is the main terminal

Tiny

Ramza666

December, 3, 2008 AT 3:47 PM

I dont have a voltage tester.

Tiny

Ramza666

December, 3, 2008 AT 4:04 PM

When I jump the car, and let it run, I believe that if the alternator was functioning it should run without the battery. However when I remove the battery cable, the car dies. Does this mean that my alternator is installed incorrectly?

Tiny

mhpautos

December, 3, 2008 AT 7:15 PM

HI there,

You should never run the engine with the battery disconnected, you can cook the ECU so easily and do other electrical damage, but as you have done so, it only shows that the battery voltage is enough to run the required systems, you will need to get the alternator readings so I can sort out your problem.
Mark (mhpautos)

Please login or register to post a reply.

Alternator testing done right
Alternator Replacement Chevrolet Silverado
Alternator Replacement Ford Super Duty
Serpentine Belt Replacement Chevy 1500
Serpentine Belt Replacement Saturn Vue
Serpentine Belt Replacement Mercedes Benz ML