DPF/EGR limp mode dash lights

Tiny
BRENNANB
  • MEMBER
  • 2009 VOLKSWAGEN POLO
  • 1.6L
  • 4 CYL
  • TURBO
  • 2WD
  • MANUAL
  • 81,000 MILES
I have a 1.6 TDI and have error codes:

P040300 - Exhaust gas recirculation circuit - passive/sporadic

P245500 - Diesel particulate filter differential pressure sensor circuit high - passive/sporadic


The glow plug light comes on now and then sometimes flashing sometimes steady, Sometimes goes into limp mode have tried many motorway runs but nothing. Best way to fix this? Is the DPF triggering engine management light would a new DPF sensor and EGR delete sort this? Thanks
Do you
have the same problem?
Yes
No
Tuesday, August 25th, 2020 AT 9:03 AM

3 Replies

Tiny
4DRTOM
  • EXPERT
Hello,

Yes, the DPF sensor could be triggering the code or a bad connection in the harness. Replacing that sensor may take care of it. You may have soot build up too that's triggering the code. Are you having performance issue when its not in Limp mode. How often is it going into Limp? Running some treatment trough it may help as well.
Tom
Was this
answer
helpful?
Yes
No
Tuesday, August 25th, 2020 AT 9:18 AM
Tiny
BRENNANB
  • MEMBER
No not at all, if anything I have noticed it feels smoother which is odd. Just had a service too and I do tend to drive around 30 miles to work and then 30 miles back. It goes into limp mode every now and then like I said the glow plug light comes on every so often. Could be once every few days or every time I start. It seems to be random. I have tried Wynn's EGR cleaner adding to the fuel and also the spray into the air intake but nothing. I think the best bet would be replacing the DPF sensor and VCDS calibrating it?
Was this
answer
helpful?
Yes
No
Tuesday, August 25th, 2020 AT 9:22 AM
Tiny
4DRTOM
  • EXPERT
Yes, if your performance is good check your wire connections and do the sensor and you'll probably be just fine.
Tom
Was this
answer
helpful?
Yes
No
+1
Tuesday, August 25th, 2020 AT 10:22 AM

Please login or register to post a reply.

Sponsored links