1997 Dodge Truck tranny stays in limp mode

Tiny
COREY HODGES
  • MEMBER
  • 1997 DODGE TRUCK
Transmission problem
1997 Dodge Truck 6 cyl Automatic

tranny was rebuilt the od sprag directclutch steels rear extension housing bearing and converter was all replaced along with an intermidiate band after reinstalling twice it still will not shift out of second gear the only shift it will make is if you manually pull shift lever down to first the main reason for overhaul in the first place was the truck worked good cold but slipped while warm direct and forward clutchs were burnt badly as well as intermidate band the over drive section also held burnt clutchs broken sprag and wore out extention housing bearing all were replaced with new transtar parts ive been in the unit three times please help before I become this trucks lunch agian 1997 dodge ram 2500 disel
Do you
have the same problem?
Yes
No
Sunday, March 14th, 2010 AT 11:21 PM

7 Replies

Tiny
DOCFIXIT
  • EXPERT
Have you scanned for codes?
Was this
answer
helpful?
Yes
No
Monday, March 22nd, 2010 AT 8:35 AM
Tiny
COREY HODGES
  • MEMBER
No codes present ive replaced gov. Press sol valve body and vss speed sensor nothing has changed
Was this
answer
helpful?
Yes
No
Tuesday, March 23rd, 2010 AT 10:59 AM
Tiny
DOCFIXIT
  • EXPERT
Need to have diagnostic scan tool to check out sensors and solenoid operation. A code reader cannot determine what is at fault. What type scan tool was used?
Was this
answer
helpful?
Yes
No
Tuesday, March 23rd, 2010 AT 3:03 PM
Tiny
COREY HODGES
  • MEMBER
Snapon modis also tried shifting with shaffer shifter which would not shift unit either while checking power to trans I noticed speed sensor had small amount of voltage to both wires one green with black stripe the other blue with black stripe shouldnt blue and black be a ground from comp.
Was this
answer
helpful?
Yes
No
Tuesday, March 23rd, 2010 AT 8:49 PM
Tiny
DOCFIXIT
  • EXPERT
Your describing wiring to Output Shaft sensor and un pluged 5 VDC on green/blk and ground on Blue/blk. Can't see how trns is in limp mode and no codes??
With Modis monitor Output sensor and VSS if they are not same trans will go into limp.


http://www.2carpros.com/forum/automotive_pictures/198357_Graphic_413.jpg


http://www.2carpros.com/forum/automotive_pictures/198357_Grafic_3_111.jpg

Was this
answer
helpful?
Yes
No
Wednesday, March 24th, 2010 AT 8:41 AM
Tiny
COREY HODGES
  • MEMBER
Modis shows data stream n/a im at a lost for words status on this truck I dont know what else to do all I know is the truck stays in second gear no matter what I do even if I disconnect all power to trans and manuly shift gonna check acumulater pressure in the am if it checks out good all I know to do is give up and refund all monies back to cust. Its allready to deep in my pocket
Was this
answer
helpful?
Yes
No
Wednesday, March 24th, 2010 AT 11:31 PM
Tiny
DOCFIXIT
  • EXPERT
O.K. No codes and solenoids unpluged sameo then must be hard part failure. Possible things sticking governor, governor electrical circuit fault, valve body ie. Stuck shift valve, front servo piston cocked in bore or malfunction front band linkage
Was this
answer
helpful?
Yes
No
Thursday, March 25th, 2010 AT 12:38 PM

Please login or register to post a reply.

Recommended Guides