SENSORS OR TRANSMISSION?

1996 Dodge Stratus

Tiny

agplkrs8

April, 24, 2008 AT 10:56 AM

Transmission problem
1996 Dodge Stratus 4 cyl Four Wheel Drive Automatic 120k miles

Hello, after 10-15 min driving, the car tursn or changes automatically running only on 1st, not changing to 2nd, 3rd or 4th.
It only happends after driving over 10-15 min. You may wonder if the car heats up, no does not, it has gas, oil and everything.
A mechanic told me it had something to do with the sensors; AutoZone told me to see the manufacturer vendor since this was a transmission issue.
Just need to know what is your expert opinion.
Is it a transmission problem or has something to do with sensors?
Please reply to me if you have any questions, I will answer quickly.
Thanks!

FOUND 148 RELATED QUESTIONS

2 Answers

Tiny

BMRFIXIT

April, 24, 2008 AT 8:45 PM

Do you have a check engine light on
have it scanned for code s
let me know the code
you need to scan(TCM) the tranny computer for the codes

most common is tranny solenoid

Tiny

BMRFIXIT

May, 1, 2008 AT 7:47 PM

P0401
inspect EGR vacuum lines inspect EGR valve gasket
inspect exhaust system for leak and repair
check EGR valve remove and clean if needed if sticking replace
check EGR solenoid and electric connection
inspect manifold and tube for restriction

check all hoses


http://www.2carpros.com/forum/automotive_pictures/99387_egr_95_1.jpg

Please login or register to post a reply.

Transmission Speed Sensor Replacement Honda
Transmission Turbine Sensor Replacement
How to gather codes Ford Explorer
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear
Code Read Retrieval/Clear Mercedes Benz
 Step by Step video GMC Yukon XL 2000-2006