OIL PRESSURE ZERO - CAR RUNS

Dodge Ram

Tiny

ritwingr

January, 27, 2007 AT 8:48 PM

1999 Dodge Ram Van with just under 61,000 miles.

For some time I have noticed an occasional soft clicking sound from under the hood. Like the sound of a baseball card in bike spokes except muffled. It has run fine, except for the pickup hasn't been great. Slow to accelerate.

I had some electrical problems, and just picked up the car after being in the shop for 2 weeks. And now the oil pressure guage is reading ZERO!

YET. The car is running ok. I'm afraid to drive it much, though. Two questions:

First, obviously, what might be the issue. Second, could the guys at the shop have done something to my car? The oil pressure was fine before it went it. (They were fixing a problem with the motor that moves the ront seat back and forth.)

Thanks in advance!
Ed

FOUND 707 RELATED QUESTIONS

1 Answer

Tiny

Service Writer

January, 27, 2007 AT 9:13 PM

Hey Ed.
I don't see a connection betwen the two, but you could present it them to please look over there work in case. Not sure on the ticking or performance just yet.

The low oil pressure is the biigie right now. It may be a bad oil sending unit. Should get the oil pressure checked awith a separate gauge, or try a new sending unit. Cost of replacing the unit may be comparable to checking the oil pressure.

Please login or register to post a reply.

Engine Oil Change and Filter Mercedes
Engine Oil Change and Filter Scion xD
Engine Oil Change and Filter Saturn Vue
Engine Oil Change and Filter Chevrolet Camaro
Engine Oil Change and Filter Mercedes ML350
Oil Change & Filter Replacement Toyota
Oil Change and Filter Replacement Ford