2005 Dodge Ram Alternator troubles

Tiny
FASTENAL01
  • MEMBER
  • 2005 DODGE RAM
  • V8
  • 4WD
  • AUTOMATIC
  • 84,000 MILES
The alternator recently went out on my truck so the first thing I did was go have it rebuilt. That didn't seem to work so I took it back and had some more new stuff put in and still nothing so I just ordered a new one directly from bosch. I installed this one and it still isn't working. When you turn the truck on the battery gage goes up about a quater of the way then about a minute later it just drops all the way down. After alot of running tests and checking fuses I have determined that I am not getting power from the computer system. I do have power from the battery. I haven't been able to find any fuses blown or and tears or breaks in the wire so far. Do you have any ideas what could be causing this? If so is this something I could fix or do I just need to take it to the dealership to get it fixed?
Do you
have the same problem?
Yes
No
Wednesday, October 14th, 2009 AT 6:57 PM

5 Replies

Tiny
BIG_JAY
  • MEMBER
Do you have power at the wire in the back of the alternator from the battery? If so then I will have to do some research to see what activates the alt.
Was this
answer
helpful?
Yes
No
Wednesday, October 14th, 2009 AT 7:13 PM
Tiny
FASTENAL01
  • MEMBER
Yes I have power there. My cousin used to be a mechanic at a dodge dealership so I asked him for help. He told me that if I have power there then I need to take the other wire off the back of the alternator (the one that is a clip with two wires coming into it) and turn the key on and I should have power to that. When I did that I got nothing so that's why I am assuming it has to be something to do with the PCM. I also took it to a little shop close to my work and they said the same thing that it had to be something to do with the PCM and they weren't able to fix it and reccomended that I take it to the dealship.
Was this
answer
helpful?
Yes
No
Wednesday, October 14th, 2009 AT 7:21 PM
Tiny
BIG_JAY
  • MEMBER
If you can wait till tomorrow I will look up some thing on it when I get to work. If u post here in the am I will get the notifacation on my phone and will respond with some suggestions.
Was this
answer
helpful?
Yes
No
Wednesday, October 14th, 2009 AT 7:27 PM
Tiny
FASTENAL01
  • MEMBER
Yeah I can wait I left the truck parked at my work I couldn't really do anything else with it I live to far away to make get it back home. I really appreciate it if you could get back with me tomorrow that would be great. I may not be able to get on this site at work so it you want you can just shoot me an email at jpettit@fastenal. Com thanks for your help
Was this
answer
helpful?
Yes
No
Wednesday, October 14th, 2009 AT 7:37 PM
Tiny
BIG_JAY
  • MEMBER
Ok sry it took me so long to get back to you. You need to locate a dark green wire on pin 10 of your PCM. Then you need to peel back a little bit of the insulator and ground the wire to the body or battery. If it still doesn't charge check for power at the alt on both terminals of the plug. If there is voltage at both terminals check the dark green wire for a break at the molded connector. If it is not broken replace the PCM!
Was this
answer
helpful?
Yes
No
Friday, October 16th, 2009 AT 9:14 AM

Please login or register to post a reply.

Recommended Guides