2000 Dodge Ram 1500 Sport with a P0108 code and bucking

Tiny
HANDYMAN09
  • MEMBER
  • 2000 DODGE RAM
I have a 00' with 110,000 on a strong and slightly modified 318 magnum. I installed an aftermarket ATI Procharger about 7 months ago W/ 11# of intercooled boost. For the past 2 months I have had the scanner on the truck testing almost everything. I can't find anyone with an accurate diagnosis to help me or lead me down the right path with my truck. I'm getting a P0108 map sensor code on and off (But I don't know if this is a false code caused but another underling problem). I replaced the sensor and ran the test in all data & Mitchell online and it passes, actually the old map sensor passed too but I changed it anyway just to eliminate the doubt. Intermittently but more frequently these days, the truck stumbles lightly once at exactly 2100rpm and at exactly at 3000rpm it bucks hard, chugs, and eventually falls flat on its face if I floor it. The severity of the symptoms depends on how deep into the pedal I am, (Light throttle =Light bucking)(WOT = Heavy bucking, back firing, and eventually complete power drop out).
It kicks down and gets better if I let up all the way and then floor it right after it starts to buck at 3000rpm. The other night I disconnected the blower to see if it had the same bucking, and not once did it buck or give me a code. I really hammered the "S*^$" out of it, so it has to be something to do with the blower. I called the so called techs for the 10th time now at ATI, basically they told me that they help me all that they could and it's my problem now. I checked what they asked of me and reported the findings.
I use to be a Tech till I ran into this problem, I ran all the basics and many advances tests and I remember most of the data I recorded. Readings from Snap-On Mt2500 & Fluke 88 & OTC Genesis and other gauges.
HELP! Thanks for any help at all.
Do you
have the same problem?
Yes
No
Thursday, November 8th, 2007 AT 7:15 PM

16 Replies

Tiny
JACK42
  • MEMBER
Is the MAP located in a part of the intake that is becoming pressurized? It might not like that much pressure if it is, unless it is designed to read that much press instead of vacuum.
Was this
answer
helpful?
Yes
No
Friday, November 9th, 2007 AT 12:00 PM
Tiny
HANDYMAN09
  • MEMBER
The map sensor is located on the throttle body and should get some of the boost pressure, I was told by the techs @ ATI to make a bleed off check valve set up and that would keep positive boost pressure away from the sensor. It didn't make any difference. I wish it were that simple to fix.
Was this
answer
helpful?
Yes
No
Friday, November 9th, 2007 AT 8:15 PM
Tiny
JACK42
  • MEMBER
What is th manifold vacuum reading at idle? And is it steady? If the engine is cammed, it can mess with the MAP too. Im just throwing thoughts out there as im sure you have heard before
Was this
answer
helpful?
Yes
No
Saturday, November 10th, 2007 AT 7:27 AM
Tiny
HANDYMAN09
  • MEMBER
The idling vacuum is a steady 20", just tonight on the parkway I have see it as high as 27" when I let up off the gas after a high speed deceleration. And the cam is stock. The mods I have done to the motor are Forged slugs, molly rings, 1/4 thick aluminum manifold pan with updated steel gasket (Dodge is infamous for blowing them out). Harland Sharp 1.6 roller rockers, JBL headers, Duel electric fans, ATI blower, Flowmaster w/2 1/2 duels, I adjusted the tps sensor to.74 volts@ idle. I relocated the Air intake sensor to the front of the cold air intake. I just installed Autolite 3923's gapped @.035 (A colder plug), New Accell cap & rotor, Set sync to 0 after installing new stuff. Taylor 10.4 mm wires Mallory boost retard timing computer(Not setup to retard -don't need it yet, spark box only).I did a stage 2 shift kit from Trans Go and put a 1/2 watt resistor inline on the PCM Connection coming from the governor pressure solenoid (It keep the PCM from kicking a 1753 code and putting me in limp mode). Some of the tests I did so far =Fuel Pressure is 46#, The leak down test was good, The Sync was set to 0 recently was off by 3 or 4 on the + side, Tps was made adjustable set to.74 V -4.87 @WOT (Smooth voltage rise and fall), Injector resistance test was good (all fell around 13.5 Ohms), Map Sensor passed all tests. IAC ok, O2 sensors ok (new also), Ground and power test for PCM on A22, A2, B+, A31, A32 for Map sensor circuit. Wiggle and tap test on all wires and connections. Voltage drop test on engine and frame grounds and power lines. Charging system tested Good. And some other tests I can't remember off hand.
Was this
answer
helpful?
Yes
No
Saturday, November 10th, 2007 AT 7:24 PM
Tiny
JACK42
  • MEMBER
I dont really know what to tell you. With all the aftermarket stuff on there might not find the problem.I went round and round with Kenne Bell about something similar and got nowhere, put the truck back to stock and drove great. This sounds like you have tested everything there is to test. Does it have an EGR system on it?
Was this
answer
helpful?
Yes
No
Sunday, November 11th, 2007 AT 8:34 AM
Tiny
GOFASTGRAY
  • MEMBER
Bump so I can PM you (9 to go)
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:47 PM
Tiny
GOFASTGRAY
  • MEMBER
8 to go
not spam. Need 10 posts to ask a question :(
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:48 PM
Tiny
GOFASTGRAY
  • MEMBER
Lucky 7
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:48 PM
Tiny
GOFASTGRAY
  • MEMBER
No. 6
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:48 PM
Tiny
GOFASTGRAY
  • MEMBER
Johny 5 is alive
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:49 PM
Tiny
GOFASTGRAY
  • MEMBER
I'm getting there/ 4 to go
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:49 PM
Tiny
GOFASTGRAY
  • MEMBER
3 is my lucky number
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:50 PM
Tiny
GOFASTGRAY
  • MEMBER
2!
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:50 PM
Tiny
GOFASTGRAY
  • MEMBER
Almost time to send a PM.
Same issue. Need to see if you've fixed yours.
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:51 PM
Tiny
GOFASTGRAY
  • MEMBER
1 for good luck. Do I have 10 yet
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:51 PM
Tiny
GOFASTGRAY
  • MEMBER
Now no.10
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:52 PM

Please login or register to post a reply.

Recommended Guides