1995 Dodge Ram Engine Runs terrible cold, fine warm.

Tiny
BLONG4LIFE
  • MEMBER
  • 1995 DODGE RAM
Engine Performance problem
1995 Dodge Ram V8 Four Wheel Drive Automatic 5.9 miles

95 Dodge Ram 2500 5.9L Gas 4x4.

Hello,

Problem is, when my motor is cold, it runs bad, backfiring (sounds like a popcorn machine). Once the computer hits 180 or so, the problem just seems to go away.

Problem is, when you hit the gas while it's doing this, it just bogs out. Sometimes stalling. Also causing erratic idle issues.

Truck has new timing chain, alternator, all 16 valves replaced, and a new crank sensor.

Thanks for the help.
Do you
have the same problem?
Yes
No
Monday, February 22nd, 2010 AT 4:09 PM

9 Replies

Tiny
SCOTTY DEE
  • MEMBER
Are there any trouble codes present?
Was this
answer
helpful?
Yes
No
Monday, February 22nd, 2010 AT 6:37 PM
Tiny
BLONG4LIFE
  • MEMBER
O2 sensor too lean. Fuel pressure is good, too (45 psi, spec is 49, within 5 PSI)

plenium was bad, had a clogged cat, for now I did gut the cat, but the sensor is before the o2 sensor, don't know if this would affect the reading, there is no post-cat o2 sensor.

Trans over temp too -- but that shouldn't apply to this.
Was this
answer
helpful?
Yes
No
Monday, February 22nd, 2010 AT 8:03 PM
Tiny
SCOTTY DEE
  • MEMBER
Can you tell me what the present codes are? I need the code numbers.
Was this
answer
helpful?
Yes
No
Monday, March 1st, 2010 AT 2:54 PM
Tiny
BLONG4LIFE
  • MEMBER
Currently no codes are present (self-reset), IIRC it was code 43.
Was this
answer
helpful?
Yes
No
Tuesday, March 2nd, 2010 AT 9:02 PM
Tiny
EDDIE7644
  • MEMBER
Try taking the O2 sensor out of the exhaust, (the one before the cat) and start it and see how it runs. THis will tell you if your cat is bad it should run good with it out.
Was this
answer
helpful?
Yes
No
Friday, March 5th, 2010 AT 3:01 PM
Tiny
BLONG4LIFE
  • MEMBER
Cat is already know to be bad and gutted.

Took it to someone I know with a DRB3, said Sync between camshaft and crankshaft sensors was off. New crank sensor, replaced cam sensor last night. Ran better but still iffy this morning, I ran some sea foam through the vaccumm lines and changed the oil, and I'll see how to does tommorrow morning.
Was this
answer
helpful?
Yes
No
Friday, March 5th, 2010 AT 3:37 PM
Tiny
2CARPROS LINSEY
  • MEMBER
Hi, Thank you for using 2CarPros. Com. We appreciate your donation and look forward to helping you in the future.
Was this
answer
helpful?
Yes
No
Tuesday, March 9th, 2010 AT 4:48 PM
Tiny
BLONG4LIFE
  • MEMBER
Problem still persists, ordering a computer for it.
Was this
answer
helpful?
Yes
No
Tuesday, March 9th, 2010 AT 8:41 PM
Tiny
2CARPROS LINSEY
  • MEMBER
Please let us know how it all turns out. Thanks again for using 2carpros. Com.
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 4:23 PM

Please login or register to post a reply.

Recommended Guides