1997 Dodge Neon loosing power

Tiny
JITUKALI
  • MEMBER
  • 1997 DODGE NEON
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 126,000 MILES
Its Neon SOHC, it looses power when you drive and sometime feels like its about to shut off, and its start fine with no problem. And it produce very balck smoke

I've replaced New EGR valve, new spark plugs, cleaned Injectors, front O2 sensor
what might be a problem.
Thanks in advance
Do you
have the same problem?
Yes
No
Monday, August 4th, 2008 AT 3:10 PM

12 Replies

Tiny
BMRFIXIT
  • EXPERT
Black smoke > to much fuel, running rich

check fuel pressure check fuel injectors for leaks
check coil and wires
Was this
answer
helpful?
Yes
No
Wednesday, August 6th, 2008 AT 9:55 PM
Tiny
JITUKALI
  • MEMBER
I've checked all the ignation components and their all fine and yesterday I had to check engine compression and vacuum lick which all turn out to be woring okay,

so I've remained with EGR Control Unit (computer) and Injector Fuel pressure Regulator to be replaced even thought on fuel pressure test didn't come out bad.

Did anyone know what tells injectors to release how much gas per engine need.
Was this
answer
helpful?
Yes
No
Thursday, August 7th, 2008 AT 8:09 AM
Tiny
BMRFIXIT
  • EXPERT
This is the compression specifications

Normal compression pressure is 170 -225 PSI
Minimum compression pressure is 100 PSI
maximum variation between cylinders 25%

fuel pressure specification is 48 PSI
with key on engine off use the scanner to activate fuel pump relay

I didnt ask before if u have check engine light on and if so what do u have for codes
good luck
Was this
answer
helpful?
Yes
No
Thursday, August 7th, 2008 AT 7:53 PM
Tiny
JITUKALI
  • MEMBER
For Engine light that was the first indication and when I checked the code was giving lean engine error (forgot the code cause it was sometime ago)
Anyway the code was for O2 sensor fairule which I replace but still kept on showing the same code which I end up replacing a brand new EGR Valve thought may be didn't work but the problem was still there thats when I checked the plug and found lots of black sooth and ans starting to notice the black smoke as well.
So for now as I posted on my previous post remain to replace computer which I might need to get the working one first and see how the engine behave and no doubt today I'll go ahead and replace Injector fuel Regulator which is attached to fuel pump.

After that I'll go ahead and erase the check engine code.
Was this
answer
helpful?
Yes
No
Friday, August 8th, 2008 AT 10:59 AM
Tiny
BMRFIXIT
  • EXPERT
Get the codes
and let see if we can solve it that way
vacuum leak will set an o2 sensor codes
Was this
answer
helpful?
Yes
No
Friday, August 8th, 2008 AT 11:34 AM
Tiny
JITUKALI
  • MEMBER
Okay I'll read the code again and will let you know
and I did check the vacum and it read okay using the tester and what I can do I'll see if I can not down all the test result and post them in here.

Thank you for you time, it just because I hate to see NEON have much similar problem sometime ago I did despose one for the same issue or at least similar problem.
Today I wish if I didn't do cause I'd have the answers
but do you know if NEON they have lots problem on the computer unit?
Was this
answer
helpful?
Yes
No
Friday, August 8th, 2008 AT 12:16 PM
Tiny
BMRFIXIT
  • EXPERT
Not usually
computer very really fail on them
Was this
answer
helpful?
Yes
No
Friday, August 8th, 2008 AT 4:38 PM
Tiny
POET042005
  • MEMBER
I have rarely seen an o2 sensor cause a car to cut off while driving. The car just tends to run rough, but thats not to say that not the cause. I have seen computers in neons set codes and then erace them selves don't ask How I have no clue. But let me add that the neon has two 02 sensors one before and after the catylitic converter if I'm spelling it right. The check engine code when it sets this code dose not tell you which one so you almost have to replace them both to fix this.

In my opinion if your problem is not ground wired coil pack related, then its your feul pump, strainer and or feul filter. Like the last post check your feul pressure before you rule out feul as posible cause.

Let me no would love to see how this turns out

Rich
Was this
answer
helpful?
Yes
No
Sunday, August 17th, 2008 AT 10:57 PM
Tiny
JITUKALI
  • MEMBER
Well up to this moment I wonder what might be wrong with the car
I've replaced Fuel Preassure Regulator, sparks plug for another tyme, wires, coil park (pulled from JY so I don't know if it works or what cause both [ original one and replaced one all behave the same])
replaced the computer still behave the same.

But I"ve notice something new on how the car behave; when it run cold, I mean in the morning start fine and idle fine but after a few minute after operative temp raise then it start missing and even when you drive it feels like you run engine with only two cylinder and thats when it will consume gas like v10.

After I replaced the computer off course the check engine light went off and I did code reader test come out negative issues but after sometime check Engine light came back test come as O2 sensor and lpoor lean on sensor bank 1,
whi I did replace O2 sensor a new one with new EGR valve.
So for now it sound like it hase miss firing and no power during drive.
Was this
answer
helpful?
Yes
No
Monday, August 18th, 2008 AT 1:49 AM
Tiny
BMRFIXIT
  • EXPERT
WHAT DO YOU HAVE FOR CODES?
Was this
answer
helpful?
Yes
No
Monday, August 18th, 2008 AT 6:05 AM
Tiny
POET042005
  • MEMBER
Another idea would be to have the timing checked along with correct gap for spark plugs, possibly timing belt could be damaged but not broken which can throw off your timing this is a long shot though, and this is only if your feul pressure checks out fine.

I am recommending having your fuel presure cheked you may need to replace your pump strainer filter and all in order to begain fixing this problem I said it like that because remember as I said before there are two seperate o2 sensors and the code does not tell you which one is bad so you pretty much have to change both to fix this problem. An o2 senser can make the car run very crapy, Ive seen this before.

Once you have feul pressure checked for proper specs let me no how it goes. Im sure we can figure this out if we follow all possible procedures.

Rich
Was this
answer
helpful?
Yes
No
Monday, August 18th, 2008 AT 11:19 PM
Tiny
ASCHWARTZ6988
  • MEMBER
Both o2 have been changed out fuel pressure is steady and only to injectors are firing 1and2
Was this
answer
helpful?
Yes
No
Saturday, June 27th, 2009 AT 9:51 PM

Please login or register to post a reply.

Recommended Guides