1996 Dodge Neon Service Engine Soon was lit

Tiny
PIGFACE
  • MEMBER
  • 1996 DODGE NEON
Computer problem
1996 Dodge Neon 4 cyl Front Wheel Drive Automatic 314+ miles

Been bothering w/ this problem for almost a year. My car will suddenly stop or no power at all even when I, m at 40 to 60 kph. I will then re-start the engine & sometimes its hard to re-start, one thing that bothers me is the "Service Engine Soon Light". The engine will vibrate even when I'm driving & the service engine soon will be on. Had checked twice w/ scanner, the first diagnosis was "map sensor no signal to pcm", I had replaced the map sensor & it costs a lot but still the service engine & the vibration of the engine comes back again, 2nd time I borrowed the computer of my friends Neon & the diagnosis was "map sensor voltage is high", but in this computer I only experienced once the vibration & had it used for a day, my car seems normal again. My technician told me to replace the computer but I have to make sure first if it is the real problem. Hope someone could help me. Thank you in advance.
Do you
have the same problem?
Yes
No
Wednesday, September 2nd, 2009 AT 8:29 AM

2 Replies

Tiny
RASMATAZ
  • MEMBER
You replaced the MAP sensor-did you check the wiring to and from the computer for short and open circuit if okay-start thinking computer-
Was this
answer
helpful?
Yes
No
Wednesday, September 2nd, 2009 AT 3:26 PM
Tiny
PIGFACE
  • MEMBER
Yes I checked it last night and I found an open wiring from the connector of map sensor & had it replaced to. But when I start the engine. It begun to vibrate again and the service engine soon light appears again. Thanks!
Was this
answer
helpful?
Yes
No
Thursday, September 3rd, 2009 AT 2:53 AM

Please login or register to post a reply.

Recommended Guides