2003 Dodge Durango Rough Idle with minimal elecrtical load.

Tiny
SANDERSHOME8240
  • MEMBER
  • 2003 DODGE DURANGO
  • V8
  • 2WD
  • AUTOMATIC
  • 80,050 MILES
I took my Durango in to a shop because of rough idle in park or stopped at a red light. Twice it has cut off without triggering dash indicators and has started back up with no problems each time. Plugs have been replaced, vacuum leak repaired, and drive belt replaced about 3 months ago and it still has episodes of rough idle. In park, RPMs bounce between 500 and 1000, dips to below 500 and then dies or nearly tries to. At the shop, there were no codes triggered to help pinpoint the problem. I have heard throttle position sensor, battery and alternator. Yesterday while out running errands, we tried to open the windows and got no response from the switches. We cut the ignition off and then restarted the truck and the windows then worked. Anybody got any ideas?
Do you
have the same problem?
Yes
No
Sunday, June 8th, 2008 AT 3:16 PM

1 Reply

Tiny
BDAKOTA95
  • MEMBER
It sounds like you may have a corroded or loose ground. Check them all as most new cars use (common) grounds that could affect multiple things. Sometimes the ecm may need an update, The battery may have volts but not enough amps(get a batt.) Or there could be some green corrosion on some connector pins. Start w/ the simple stuff and work your way to getting dirty.
Was this
answer
helpful?
Yes
No
Tuesday, July 8th, 2008 AT 7:31 PM

Please login or register to post a reply.

Recommended Guides