2003 Dodge Caravan Looses wipers, pwr windows, blower and r

Tiny
JA6001
  • MEMBER
  • 2003 DODGE CARAVAN
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 61,000 MILES
Sometimes when I start the van it looses wipers, radio, pwr windows and radio. Sometimes they just start working after awhile. If you just turn the ignition on everything works. I recently started get a speed sensor code but the engine goes out after driving awhile.
Do you
have the same problem?
Yes
No
Monday, February 25th, 2008 AT 11:03 AM

10 Replies

Tiny
JACK42
  • MEMBER
If you wiggle the key a little will they work? I have seen many Dodge ignition switch problems like this.
Was this
answer
helpful?
Yes
No
Monday, February 25th, 2008 AT 12:09 PM
Tiny
JA6001
  • MEMBER
It acts as though it may not be returning to the run position after you start the motor.I am thinking about replacing the ignition switch.
Was this
answer
helpful?
Yes
No
Monday, February 25th, 2008 AT 12:16 PM
Tiny
JACK42
  • MEMBER
Sounds like a good place to start
Was this
answer
helpful?
Yes
No
Monday, February 25th, 2008 AT 12:24 PM
Tiny
DWEEBLE
  • MEMBER
Hey same problem with the Caravan, looses all accessories when running. Did replacing the ignition switch do the trick?

Mike
Was this
answer
helpful?
Yes
No
Monday, March 3rd, 2008 AT 8:09 PM
Tiny
JA6001
  • MEMBER
No it did not, I am just going to take it to the dealer.
I have also started getting a TCM and speed sensor error. I am now begining to think it is the PCM that may be the problem.
I will post the results when I find out
Mike
Was this
answer
helpful?
Yes
No
Tuesday, March 4th, 2008 AT 7:41 AM
Tiny
DWEEBLE
  • MEMBER
I was checking around and was told to replace the ignition switch, about 42 bucks new from the dealer, so I'm going to try one. I'll let you know.
Mike
Was this
answer
helpful?
Yes
No
Tuesday, March 4th, 2008 AT 5:22 PM
Tiny
JA6001
  • MEMBER
Well I am dropping mine off at the dealers tonight so hopefully I will find out tomorrow what the problem is. I will post what they claim the fix is, so if you can hang on a couple more days I may be able to help you save some money

Mike
Was this
answer
helpful?
Yes
No
Wednesday, March 5th, 2008 AT 8:33 AM
Tiny
JA6001
  • MEMBER
Well I just heard back from the dealers. My electrical problem is from a ground problem that is internal on the IPM. The IPM is the fuse box. There is alot of things inside it now.

Mike
Was this
answer
helpful?
Yes
No
Thursday, March 6th, 2008 AT 12:12 PM
Tiny
JAYESS59
  • MEMBER
Mike.

What was needed to fix your ground problem, internal to the IPM/Fuse Box?

We are being told that we need a $700.00 electronic module to fix the same problem.

JayEss
Was this
answer
helpful?
Yes
No
Monday, March 24th, 2008 AT 5:11 PM
Tiny
JA6001
  • MEMBER
That is not far off, mine was 630.00. Not really a hard part to replace if you could find it in a salvage yard. I looked and just could not find anything that would work. I feel your pain

Mike
Was this
answer
helpful?
Yes
No
Tuesday, March 25th, 2008 AT 7:43 AM

Please login or register to post a reply.

Recommended Guides