1996 Dodge Avenger transmission

Tiny
TWINKIE08
  • MEMBER
  • 1996 DODGE AVENGER
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 126,000 MILES
Hi everyone I like to thank you for this site, because sometimes its good for people like me to ask before even going to a shop. So here is my question:

MY CAR IS A ´96 AVENGER WITH A 2.5 LITER ENGINE, AUTOMATIC TRANSMISSION, IT WAS WORKING FINE, WE STOP USING IT FOR ABOUT 18 MONTHS BECAUSE WW MOVE OUT OF TOWN WHEN WE CAME BACK THE TRANSMISSION WASN ´T WORKIG IT ONLY STAY IN 2ND. GEAR WHAT I MEAN IS THAT IT ONLY STAY IN ONE GAR AND NEVER CHANGE.
I WAS THINKING AT THE TRANSMISSION CONTROL SOLENOID?
SO IF YOU HAVE ANY CLUES LET ME KNOW I WILL APRECCIATE. THANKS
Do you
have the same problem?
Yes
No
Monday, November 30th, 2009 AT 8:34 PM

5 Replies

Tiny
MHPAUTOS
  • EXPERT
Hi there,

This may just be a stuck shift valve or solinoid, go get it serviced at a transmission work shop, they will also be able to give you a report on any problem that they may find.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Monday, November 30th, 2009 AT 8:38 PM
Tiny
TDCRAIG
  • MEMBER
Having same problem did you fix problem?
Was this
answer
helpful?
Yes
No
Friday, January 29th, 2010 AT 10:42 AM
Tiny
TDCRAIG
  • MEMBER
Having same problem did you find solution?
Was this
answer
helpful?
Yes
No
Friday, January 29th, 2010 AT 10:45 AM
Tiny
TDCRAIG
  • MEMBER
Was this
answer
helpful?
Yes
No
Friday, January 29th, 2010 AT 10:48 AM
Tiny
JUANLANAS13
  • MEMBER
The tranny is in limp mode and stays in second gear so that the tranny dose not hurt itself. I would replace the tranny filter and fluid first. Then take it to a shop so they can hook up a reader. Make sure you put ATF+4 fluid
Was this
answer
helpful?
Yes
No
Monday, February 1st, 2010 AT 8:29 PM

Please login or register to post a reply.

Recommended Guides