Defroster (front)

Tiny
BRENDA MCGRAW
  • MEMBER
  • 1990 FORD AEROSTAR
  • 4.0L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 150,000 MILES
My front defrost barely blows any air and the air never gets very warm, it takes for ever to defrost the window.
Sunday, November 19th, 2017 AT 11:43 PM

4 Replies

Tiny
WRENCHTECH
  • MECHANIC
  • 20,758 POSTS
With the engine at full operating temp, locate the two heater hoses where they go into the firewall and feel them to see if they are both hot to the touch. If they are both hot, the heat in that vehicle is controlled by a blend door that regulates heated air flow. It is operated by a cable in this vehicle. The problem can be that the cable has broken or come off. This is what needs to be determined by examining the cable connection and see if it is responding to heat change commands or not.
Was this
answer
helpful?
Yes
No
+1
Monday, November 20th, 2017 AT 2:55 PM
Tiny
WRENCHTECH
  • MECHANIC
  • 20,758 POSTS
This truck should also have a coolant control valve on the engine side that needs to have operation confirmed. Picture below.
Was this
answer
helpful?
Yes
No
Monday, November 20th, 2017 AT 3:00 PM
Tiny
BRENDA MCGRAW
  • MEMBER
  • 16 POSTS
Thank you, I will check both of these areas out.
Was this
answer
helpful?
Yes
No
Tuesday, November 21st, 2017 AT 1:26 AM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,711 POSTS
Please let us know what you find. We are interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Friday, November 24th, 2017 AT 6:26 PM

Please login or register to post a reply.

Sponsored links