2000 Daewoo Leganza No Spark No MIL check engine light at I

Tiny
CALWASH
  • MEMBER
  • 2000 DAEWOO LEGANZA
Electrical problem
2000 Daewoo Leganza 4 cyl Two Wheel Drive Automatic

Does "check engine" (MIL) dash light bulb comes on at ignition or briefly after start up.
I changed timing belt and had head rebuilt.
Assembled and now NO Spark and no MIL light at ignition turn on.
Replace ECM 2x, COIL pack and still no spark.
ECM ground ok, ECM fuse good, 12v feed wires good to ecm. Traced wires to ECM all good.
BUT NO MIL LIGHT at ignition.
OBD scanner shows all is ok or? No bad codes.
Manual says if feed wires are good and ground is good and you don't have MIL light on at ignition then ECM is bad. Tried replacing.
Does check engine light come on before or after start of car to test bulb.
If Cam/crank sensor is a problem, still wouldn't the MIL light come on when key turned. I have spark tester. Thanks for any tips. Ken
Do you
have the same problem?
Yes
No
Saturday, October 25th, 2008 AT 1:28 AM

5 Replies

Tiny
JASONRAY
  • MEMBER
Does the vehicle have a Mass Airflow sensor? One time, and one time only, I diagnosed a bad mass airflow sensor on one with similar symptoms. When you turned the key on, and the MIL came on, the vehicle would start. But if you turned it on, and the light DID NOT come on, the car would NOT start. After following procedures, I was led to the MAF sensor. I was instructed to UNPLUG the sensor and note the operation of the MIL. When the vehicle was not working properly, (the light DID NOT come on with the key on) I unplugged the MAF. When I did, the light came on. This told me to replace the sensor. I did and it worked fine. Wouldn't it be great if this procedure worked for you? Try it and see. IF not, re-post and we'll try another avenue.
Was this
answer
helpful?
Yes
No
Saturday, October 25th, 2008 AT 1:24 PM
Tiny
CALWASH
  • MEMBER
I am trying to find MAF sensor with Mitchell (onDemand 5) software. As I'm understanding it controls Evap or EGR working with ECM. I'm reading about theory and operation with this software but not convinced this car has one?
For MAF location the software leads me to Engine performance "wiring diagram" but can't find MAF or Mass Airflow in diagrams at all.
I'll keep trying. Boy ! I sure hope that MAF is it.
With other sensors that are on this car it gives location with diagrams. But not with MAF.
Ken
Was this
answer
helpful?
Yes
No
Saturday, November 1st, 2008 AT 12:21 PM
Tiny
JASONRAY
  • MEMBER
Some vehicles do NOT have/use a MAF sensor. If it has one, it will be in the air intake duct between the air filter and the throttle body. I don't have a diagram in front of me right now or I would be more help. It will possibly be 'in line' in the duct with a medium sized connector attached to it. Possibly 8 to 15 or so wires.
Was this
answer
helpful?
Yes
No
Wednesday, November 5th, 2008 AT 5:41 PM
Tiny
CALWASH
  • MEMBER
There is a small 2 wire sensor in air duct. (Very small)
I plugged it in for the 1st time and still no MIL light at ignition.I am trying to wiggle wires as I turn ignition trying to find something.
Do you think Crank sensor, Cam sensor Even though No MIL light at ignition. Wiggle Wiggle Wiggle grounds.
At a loss. Thanks for your help.
Kenny
Was this
answer
helpful?
Yes
No
Thursday, November 6th, 2008 AT 6:54 PM
Tiny
CALWASH
  • MEMBER
I wonder if a bad Crank sensor would cause a No Mil Light situation?
Also Is there ANY chance Mil light comes on after car starts briefly instead of at ignition?
I keep wiggling wires checking grounds etc.
Even the actual wire that goes to Mil Light I grounded to just see if light will come on and it doesn't.
Many Thanks Ken
Was this
answer
helpful?
Yes
No
Monday, November 10th, 2008 AT 5:31 PM

Please login or register to post a reply.

Recommended Guides