2000 Daewoo Leganza no heat

Tiny
RONCO
  • MEMBER
  • 2000 DAEWOO LEGANZA
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 91,000 MILES
Guage stays cold for long time then even when it comes up to mid range it gives very little warmth. Only one hose is hot to it under the hood but I've heard something about a clip that holds the heater core in place. Wondered how to remove the core? Should I try to buy any parts in advance or could it be just this clip?
Do you
have the same problem?
Yes
No
Wednesday, January 23rd, 2008 AT 6:58 PM

2 Replies

Tiny
BMRFIXIT
  • EXPERT
Change thermostat 1st
engine not heating up for the heat to work
Was this
answer
helpful?
Yes
No
Wednesday, January 23rd, 2008 AT 8:38 PM
Tiny
YOBOBYO
  • MEMBER
This happen to me. If you let the coolant get to dirty, or you have to much sediment in the coolant. It will clog you heater core.
First, and for most, let the car cool down! Don't work on a hot car. Even cool, the coolant might still be very hot! Once the car is cooled off.
You'll have to remove the two heater hose.
Once remove, you'll blow air thru the heater hose that comes off the side of the motor. Not the one in the back. This will push any thing that might be clogging the core back thru and free it up. Sometimes it does need a little pressure. But be careful, don't over do it. Understand that once you push the clog out, it will leave a mess coming out of the other hose. So you might want to stick the other hose in something to catch the stuff coming out.
Was this
answer
helpful?
Yes
No
+1
Monday, October 6th, 2008 AT 8:00 PM

Please login or register to post a reply.

Recommended Guides