Crank sensor relearn

Tiny
HARRY61
  • MEMBER
  • 1998 PONTIAC GRAND PRIX
  • 3.8L
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 190,000 MILES
I have a 1998 Grand Prix that I replaced the crank sensor, After I replaced it I found out I had a blown head gasket, After getting that fixed I took it down to a local shop to have the case relearn done, The mechanic doing it said it wasn't accepting the relearn, He said that it could be a few things and to check all the plug ins on the motor, I checked them all there all good, He said it can even be the Ecu, Is there anything else I can check before before investing in a Ecu?
Do you
have the same problem?
Yes
No
Sunday, April 3rd, 2016 AT 4:33 AM

7 Replies

Tiny
HMAC300
  • EXPERT
Try resetting security system or another key if you have one it may be the security system causing problem. Ecu will relearn as you drive. Crank sensor as well
Was this
answer
helpful?
Yes
No
Sunday, April 3rd, 2016 AT 9:02 AM
Tiny
HARRY61
  • MEMBER
My car don't have a security system!How long or how many miles would it take for the Ecu and the crank sensor to relearn?
Was this
answer
helpful?
Yes
No
Wednesday, April 6th, 2016 AT 9:11 PM
Tiny
HMAC300
  • EXPERT
Your car does have a security system they all do since mid 90's it relearns as you drive don't worry about it
Was this
answer
helpful?
Yes
No
Thursday, April 7th, 2016 AT 6:19 AM
Tiny
HARRY61
  • MEMBER
Well now more problems, After driving my car hundreds of miles it still didn't relearn after the crank sensor was replaced, Here' another problem, while driving it yesterday I noticed the temp gauge was climbing pretty fast so I pulled over opened the hood and the heater hose had a hole right above the hose clamp.I waited for it to cool off a bit, cut the hose and placed it back, didnt have any antifreeze so put in a gallon of water, got about half mile and started overheating again so I stopped and let it cool, after it cooled it would not start even with a jump box so sat and waited for my wife with a fresh battery. After installing the fresh battery it started and now wont go over 20 miles an hour and still getting hot !
Was this
answer
helpful?
Yes
No
Saturday, May 14th, 2016 AT 8:54 AM
Tiny
HMAC300
  • EXPERT
You probably have a head gasket gone on this plus it needs to be rescanned to see the cause of the low mph.
Was this
answer
helpful?
Yes
No
Saturday, May 14th, 2016 AT 4:22 PM
Tiny
HARRY61
  • MEMBER
I just had the head gasket done less than 2 months ago it cost me almost a 1000.00
Was this
answer
helpful?
Yes
No
Saturday, May 14th, 2016 AT 8:33 PM
Tiny
HMAC300
  • EXPERT
Then if you had head gasket replaced check thermostat and radiator for cold spots if you have cold spots when car is hot rad is not good. But it still needs to be scanned for codes for not allowing it to go faster than 20
Was this
answer
helpful?
Yes
No
Sunday, May 15th, 2016 AT 8:22 AM

Please login or register to post a reply.

Recommended Guides