Cooling Fans will not turn on

Tiny
SHALEN WILLIAMS
  • MEMBER
  • 2008 CHEVROLET MALIBU
  • 2.4L
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 195,300 MILES
The cooling fans will not turn on causing the engine to overheat.

I have already replaced the engine coolant temperature sensor and both fan relays. I have tested the wires from the sensor to the ECM and ground and they are good. The fans come on 100% when I unplug the coolant temperature sensor for safe mode. I also replaced the relay for the air conditioner compressor and that system works correctly (I read that the two systems are connected).

I am at a loss, any help would be wonderful.
Do you
have the same problem?
Yes
No
Wednesday, July 27th, 2016 AT 8:48 AM

3 Replies

Tiny
HMAC300
  • EXPERT
I am assuming you have checked the fuse as well for the fans along with the relays which you said you did. There are three relays for fans and ground is near #4 exhaust port. Also check ground for fans and diode might be messed up. See pictures.
Was this
answer
helpful?
Yes
No
Wednesday, July 27th, 2016 AT 9:36 AM
Tiny
SHALEN WILLIAMS
  • MEMBER
Yes, I checked the fuses as well. I will check the grounds when I get off work this afternoon. If the ground was not connected wouldn't that keep the fans from coming on at all?
Was this
answer
helpful?
Yes
No
Wednesday, July 27th, 2016 AT 9:43 AM
Tiny
HMAC300
  • EXPERT
If the ground is poor or disconnected the fans wont work. The fan grounds may be on the header where radiator is bolted to.
Was this
answer
helpful?
Yes
No
Wednesday, July 27th, 2016 AT 12:04 PM

Please login or register to post a reply.

Recommended Guides