I switch the vehicle on, the Climate Control is not working

Tiny
WN.BEKKER@GMAIL.COM
  • MEMBER
  • 2013 FORD F-150
  • 6.2L
  • V8
  • 4WD
  • AUTOMATIC
  • 60,000 MILES
Sometimes when I switch the vehicle on, the Climate Control is not working, no lights, nothing. I can try to switch it on manually or on the screen, nothing as if it does not have power. Everything else in the vehicle work. When I switch the vehicle off and restart, it sometimes come back on but 90% of the time, it stay off.

If I leave the vehicle off for a long time (2-3 hours), and start again, it is working fine. I have tried the following and do not know if it really solve the problem, "temporally" or if it is only luck:

I switch the vehicle off, get out, lock the vehicle and then press the Lock Button on the key for 20 seconds, open the vehicle and start, sometimes it works and sometimes not. Please give me some direction where to find the problem.
Do you
have the same problem?
Yes
No
Tuesday, June 9th, 2020 AT 11:02 PM

1 Reply

Tiny
BMDOUBLE
  • EXPERT
The first step should be to do a scan on the HVAC module and the body control module. A CAN scan which is the future of automotive repair you can get a CAN scanner from Amazon for about $50.00 here is a video to show you how.

https://youtu.be/u-4syLc-ifQ

This will more than likely point you in the right direction versus throwing parts at your truck. I have included a diagram that will give you an idea of what is involved with the circuit. It could be something as simple as low voltage after starter engagement.
Check out the diagrams (Below). Please let us know what you find.
Was this
answer
helpful?
Yes
No
Wednesday, June 10th, 2020 AT 10:05 AM

Please login or register to post a reply.

Sponsored links