2007 Chrysler Town and Country Cooling stopped

Tiny
SCIRWIN
  • MEMBER
  • 2007 CHRYSLER TOWN AND COUNTRY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 43,000 MILES
The A/C is not longer cold - seemed to be fine during the winter.
hearing a buzzing below/behind the glove compartment.
is this possible a bad evaporator valve?
I would like to repair it myself it possible unless it requires removing and replacing the freon.
Do you
have the same problem?
Yes
No
Sunday, May 24th, 2009 AT 1:52 PM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Is the blower motor working?
Was this
answer
helpful?
Yes
No
Sunday, May 24th, 2009 AT 7:15 PM
Tiny
SCIRWIN
  • MEMBER
Yes - blower runs, this is a auto a/c temp system.
I am 99% sure I can hear the compressor engaging.
Was this
answer
helpful?
Yes
No
Monday, May 25th, 2009 AT 3:16 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If the compressor is working, then there is most likely a problem with the blend door not closing and allowing heat from the heater core to blend with the ac. The blend door is located near the heater core under the dash.
Was this
answer
helpful?
Yes
No
+1
Monday, May 25th, 2009 AT 7:12 PM
Tiny
SCIRWIN
  • MEMBER
Should one of the lines from the compressor be ice-cold?
Was this
answer
helpful?
Yes
No
Monday, May 25th, 2009 AT 8:04 PM
Tiny
SCIRWIN
  • MEMBER
Should one of the lines from the compressor be ice-cold?[/Quote:414e8adcc0]

Trying it again last night, it does not appear that the compressor is coming on.
Was this
answer
helpful?
Yes
No
Tuesday, May 26th, 2009 AT 7:46 AM

Please login or register to post a reply.

Recommended Guides