FAN SPEED CONTROL

1998 Chrysler Town and Country

Tiny

hansen403@gmail.com

January, 9, 2009 AT 4:49 PM

Heater problem
1998 Chrysler Town and Country 6 cyl Front Wheel Drive Automatic 179000 miles

I have a heater control with rear air, the front air control works only when on high. I have a new resistor for the fan which I bought after replacing the fan control module. Where will I find the fan resistor to replace it? There is anther problem with the electrical. When I start the vehicle the instrument cluster goes blank for awhile. After a half hour or more with the motor running the instruments come back on. Any ideas?

FOUND 305 RELATED QUESTIONS

2 Answers

Tiny

bluelightnin6

January, 9, 2009 AT 7:34 PM

Hello
Thanks for the donation.

For the instrument panel, check the ground wires to ensure it is grounded properly. May also need to inspect the circuit board and solder any bad spots, if experienced in doing so.

As for the blower resistor, below are removal/installation instructions along with the location of the component.


http://www.2carpros.com/forum/automotive_pictures/261618_Noname_101.jpg



FIGURE 5


http://www.2carpros.com/forum/automotive_pictures/261618_fig_3.jpg



Hope this helps..
Thanks for using 2carpros.com!

Tiny

NevadaKid

January, 15, 2009 AT 10:08 PM

I just had the same problem with my 2001.I replaced the battery (it had a bad cell and wasnt giving out enough amps). Problem fixed!

Please login or register to post a reply.

Change Your Blower Fan Motor Like a Pro