OK...AN HEATER QUESTION

Chrysler

Tiny

dcrowe7

February, 6, 2007 AT 4:01 PM

Drove into work this morning and heater was working fine. I get in after work and nothing. Nothing lights light up, no heat. Nothing. I was hoping it was just a fuse but I checked it and it is fine. I replaced it anyway just in case but I still get no response whatsoever. Any idea what else it could be.

FOUND 6255 RELATED QUESTIONS

No Heat

37 ANSWERS
5 IMAGES

3 Answers

Tiny

bootdog

February, 6, 2007 AT 5:50 PM

Can you be a little more descriptive? Are you having problems with the heat and your lights? Is the vehicle doing anything at all? Also can you give the make, model and year. Let me know and i'll help you out as soon as I can. : )

Tiny

dcrowe7

February, 6, 2007 AT 5:55 PM

Its a 1993 Suburban. The vehicle is running perfectly fine except for the heat. Lights work perfectly, as do my brake lights. Usually when I start up my truck the lights for the heater " LED" all come on. I am getting no response at all.

Tiny

bootdog

February, 6, 2007 AT 6:42 PM

Ok there are a few things you could do, replace the thermostat. It could be stuck open, also flush the heater core. You have 2 heater hoses running to the firewall. Remove the hoses and gently run water through one end of the heater core until it flows clear. You also should have a heater control valve that could be stuck shut. It usually connects to one of the heater hoses too. Look into these 3 areas for a fix. Hope the info was helpful

Please login or register to post a reply.

Cabin Air Filter Replacement
Replace Heater Core
Cabin Air Filter Replacement
Heater Hose Replacement Chevrolet Camaro
Cabin Air Filter Replacement Saturn Vue