1992 Chrysler Le Baron Engine smokes and heater doesn't wor

Tiny
JABA
  • MEMBER
  • 1992 CHRYSLER LE BARON
Heater problem
1992 Chrysler Le Baron Engine Size unknown Wheel Drive Type unknown Automatic 140k miles

A few months ago my husband removed my coolant reservoir and around that time my heater stopped working and my temperature gauge would read very high. The coolant was also very low, so after adding coolant and replacing the thermostat, the heater worked for about 2 days. I shortly noticed later that there was a significant amount of antifreeze underneath my car, which I was told was overflow from my radiator which would be going into the coolant reservoir but instead is going all over. So we kinked the hose that would go into the reservoir and added more coolant--the heater worked for a day, but now blows out cold air. Would the coolant reservoir have anything to do with this or is it probably a cracked radiator? Also, after my cars runs for a few minutes I can see a small amount of white smoke from under the hood--after opening the hood, the smoke it coming from somewhere closer to the upper part of the engine and not the radiator area--the smoke also has a gasoline smell to it. The heater now puts off a gasoline smell as well. Any ideas? Thank you for your help.
Do you
have the same problem?
Yes
No
Wednesday, December 26th, 2007 AT 11:50 AM

1 Reply

Tiny
BMRFIXIT
  • EXPERT
If you dont have the means to do coolant pressure test then you should have it done for the car it sound like you have a coolant leak in the system
check also the radiator
Was this
answer
helpful?
Yes
No
Friday, December 28th, 2007 AT 7:01 AM

Please login or register to post a reply.

Recommended Guides