1995 Chrysler Cirrus 95 Chrysler Cirrus low idle miss or bu

Tiny
ZOMBIE17240
  • MEMBER
  • 1995 CHRYSLER CIRRUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 130,000 MILES
I started my cirrus awhile back and it wouldnt run right like it wasnt firing in all cyclinders. No codes came on. I shut it off and the next day it wouldnt run at all without flooring it, and still wouldnt run longer then 5 secs. I took it to a mechanic and he came up with the dia of needing a new cat, wires and plugs, and replace the valve covers. Well when I left with the car, seemed to run fine till it warmed up to about running temp, started to misfire alot, especially on taking off from start, and it really did alot of miss firing with stopped in gear. Tried stp complete full system cleaner to it. Took away alot of lack of power, obviously still bucked or missed fired. Had another mechanic look at it, said it was the dcap, replaced it ran good for about 20min and still miss fired while idleing in gear at a complete stop. Any clue what could cause this?
Do you
have the same problem?
Yes
No
Monday, September 28th, 2009 AT 6:14 AM

3 Replies

Tiny
MATHIASO
  • MEMBER
Missfire without code is difficult to find what system is at fault.
But I can give you the list of most 10 top causing missfire, from there you can susbtract you you alleready did and waht you did not do yet.

Spark plugs ( ok)
Spark plug wires (ok)
Ignition coil
Fuel injector
Wiring to fuel injector
Timing Belt
Vacuum leak or stuck open EGR
Contaminated fuel or bad fuel pump
Weak compression
Blown head gasket

I have little question, maybe stupid one; you said" no codes come on" or "no engine light come on?"
Was this
answer
helpful?
Yes
No
Friday, October 2nd, 2009 AT 3:49 PM
Tiny
ZOMBIE17240
  • MEMBER
Nothing comes up when a code reader is applied. Ive had a compression test as well and it checked out fine. What is weird when I took it to my usual mechanic after the guy who got it running with (new plugs, wires, valve covers, cat) he found a crack in my cap, which he then replaced. It still missefissed once in a while just slightly. He put lucas fuel injector into it. It ran good for a while, well two days, and it only missed in drive at a stop, no hestitation when pulling away. I replaced the maf and pcv valve. Didnt do anything to help the problem. But when I opened the hood to replace these objects(car sitting overnight)gave me a big woof of gas smell but didnt last. The miss is very intermediate, not constant. But now that it has been a week with the problem the car seems to be getting worse, itll miss in drive, but not as pronouned, and now its even to start when you pick up acceleceration slowly itll miss, it you let off and try again it goes away. It really pronounes it self in stop and go traffic alot, likes to carry on like its gonna stall almost but not
Was this
answer
helpful?
Yes
No
Saturday, October 3rd, 2009 AT 8:35 AM
Tiny
MATHIASO
  • MEMBER
It might be fuel related. If you smell fuel when you open the hood
check fuel rail that supplies fuel to the injectors for leak.
Start the car while running open the hood, try to snif little bit around if you smell gas,
also when engine misses on accelaration, check for dirt in the fuel system, make sure the gap is not set wide on the spark plugs, burn warped or pitted valves, or you have faulty coil.
Was this
answer
helpful?
Yes
No
Saturday, October 3rd, 2009 AT 7:10 PM

Please login or register to post a reply.

Recommended Guides