Charging System

Tiny
LSTITAK
  • MEMBER
  • 2007 CHEVROLET UPLANDER
Electrical problem6 cyl Front Wheel Drive Automatic 48000 miles

The problem I am having is when the on board display is on for the charging system the alt. Output is 14.2 v while driving for several hours on the interstate the voltage will start to drop 13.9 - 13.6 - 13.2 - 12.9 - 12.6 - 12.2 it will stay at 12.2 for at least 20-30 min. Even with the a/c on then it will start to build voltage going upwards in the same increments then it will stay at 14.2 for a while then proceed back down. Once parked and the voltage at 12.2 I turned on everything headlights a/c rear defroster wiper and then the voltage started to build back up. So is the problen in the voltage regulator or is the charging system tied into the pcm and regulating voltage by demand only. I have had no problen as far as the battery being dead.
Do you
have the same problem?
Yes
No
Friday, June 18th, 2010 AT 6:43 PM

1 Reply

Tiny
KEN L
  • ADMIN
This will happen as the battery starts to go bad. The computer monitors the amperage the alternator is putting out and reduces the requirements so the alternator won't burn out. I would clean the connection and replace the battery. Here are tow guides that will help you.

https://www.2carpros.com/articles/everything-goes-dead-when-engine-is-cranked

and

https://www.2carpros.com/articles/how-to-replace-a-car-battery

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, November 6th, 2017 AT 3:21 PM

Please login or register to post a reply.

Sponsored links