Chey 1994 c 1500 coolant

Tiny
HOTDEAL
  • MEMBER
  • 1994 CHEVROLET TRUCK
1994 c1500, 4.3l eng, 128k miles, 2 wheel drive, silverado package, heavy duty towing package. Cut out cataiytic converter, put on duals with glass pack mufflers on duals. Have started loosing coolant. Problem did not show up till I put the duals on. Have slooshing sound in heater core, moisture coming ou both sides of exhaust left heaver than right. No coolant in oil or oil in the raditor. During winter or summer temp gage shows only about 80 degrees and hard to get heat during winter. Is it possible that the heater coree is clogged and is causing all my problems? : :( :(
Do you
have the same problem?
Yes
No
Monday, September 3rd, 2007 AT 2:03 AM

5 Replies

Tiny
RASMATAZ
  • MEMBER
The cooling system is nowhere associate with the exhaust system

Have you check the thermostat? If its completely closed you won't have anything in the heater core

probably the slooshing sound is boilover-you sure your temperature gauge is not misleading you-could be out of calibration.

Have the cooling system block and pressure tested-this will tell you something if its burning internally about heavy moisture coming out on one side.

Sounds like a blown headgasket
Was this
answer
helpful?
Yes
No
Monday, September 3rd, 2007 AT 5:07 AM
Tiny
HOTDEAL
  • MEMBER
CKED THERMOSTAT, ALSO PULLED ALL THE SPARK PLUGS, NO INDICATION OF COOLANT GETTING INTO TO PLUGGS, CKED WATER PUMP NO INDICATION OF LEAK, CKED ALL HOSES NO INDICATION OF THEM LEAKING : :cry:
Was this
answer
helpful?
Yes
No
Thursday, September 6th, 2007 AT 6:55 AM
Tiny
RASMATAZ
  • MEMBER
CKED THERMOSTAT, ALSO PULLED ALL THE SPARK PLUGS, NO INDICATION OF COOLANT GETTING INTO TO PLUGGS, CKED WATER PUMP NO INDICATION OF LEAK, CKED ALL HOSES NO INDICATION OF THEM LEAKING : :cry:[/quote:2902062aae]

Disconnect heater hose from engine side and try flushing it out
Was this
answer
helpful?
Yes
No
Thursday, September 6th, 2007 AT 7:50 AM
Tiny
HOTDEAL
  • MEMBER
Sorry haven't got back, but I am a truck drive n not home much. Will be in a week or 2 will do it then n report back
CKED THERMOSTAT, ALSO PULLED ALL THE SPARK PLUGS, NO INDICATION OF COOLANT GETTING INTO TO PLUGGS, CKED WATER PUMP NO INDICATION OF LEAK, CKED ALL HOSES NO INDICATION OF THEM LEAKING : :cry:[/quote:deb0ee7a91]

Disconnect heater hose from engine side and try flushing it out[/quote:deb0ee7a91]
Was this
answer
helpful?
Yes
No
Saturday, September 15th, 2007 AT 7:52 AM
Tiny
HOTDEAL
  • MEMBER
CKED THERMOSTAT, ALSO PULLED ALL THE SPARK PLUGS, NO INDICATION OF COOLANT GETTING INTO TO PLUGGS, CKED WATER PUMP NO INDICATION OF LEAK, CKED ALL HOSES NO INDICATION OF THEM LEAKING : :cry:[/quote:1d556f4ef1]

Disconnect heater hose from engine side and try flushing it out[/quote:1d556f4ef1][/quote:1d556f4ef1]

sorry haven't got back, but I am a truck drive n not home much. Will be in a week or 2 will do it then n report back
Was this
answer
helpful?
Yes
No
Saturday, September 15th, 2007 AT 7:53 AM

Please login or register to post a reply.

Recommended Guides