Not shifting

Tiny
JJMSMOOTIE
  • MEMBER
  • 1995 CHEVROLET TRUCK
V8 Automatic 105, 00 miles

No codes, speedometer working/tachometer working not slipping/just stays in one gear. I think second. Did this one other time but corrected its self very shortly. This is a 454 one ton Chevrolet pick up two wheel drive. Will donate something/will donate more if we fix problem soon as possible. Thanks, James
Do you
have the same problem?
Yes
No
Monday, November 30th, 2009 AT 10:55 AM

19 Replies

Tiny
DOCFIXIT
  • EXPERT
Hi, maybe ignition switch has been reported on Mitchell Tech Net although GM has not owned up.
Seems ignition does not power up module and PCM at same time and transmission goes into limp mode. Next time stuck in second check pink wire on transmission connector if no twelve volts then switch off and on if transmission shifts then ignition switch.
Hope this helps.
Thanks for donation.
Was this
answer
helpful?
Yes
No
+1
Monday, November 30th, 2009 AT 1:16 PM
Tiny
BUCKSHOT99
  • MEMBER
I have 1995 Chevrolet K1500 Silverado that my tachometer, speedometer, gear position indicator and odometers would not work off and on. When this happened, the transmission would start off in tall gear making it very hard to get the truck moving. Mechanic and his techs were able to troubleshoot to two different issues. My issues may be different than other trucks with the same symptoms but the Instrument cluster needed repair and ignition module needed replacement. Mechanic took the time to troubleshoot this electrical issue and was very fair on his pricing.
Was this
answer
helpful?
Yes
No
Tuesday, May 2nd, 2017 AT 12:12 PM
Tiny
LOVEPUGS4
  • MEMBER
  • 1995 CHEVROLET TRUCK
Electrical problem V8 Four Wheel Drive Automatic 191,000 miles.

My tachometer and speedometer quit, my transmission stopped shifting. Will go into gear forward or rev but seems to be starting out in higher gear and does not shift. The transmission indicator light dose not work. Tried new gauge cluster still no change. Plugged scanner up it dose read rpm's and speed. This all happened at the same time. I am thinking ECM problem?
No fault codes logged.
Thank you
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
LOVEPUGS4
  • MEMBER
I fixed this myself. It was my ignition switch it feeds power to the transmission fuse in the run position and gauges. Posted this to help someone else.
Was this
answer
helpful?
Yes
No
+4
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
TRAPPER_CANADA
  • MEMBER
Hi there,
Just this morning I believe I had a very similar thing happen. Everything quit working, engine revved, but it was not moving to well. I stopped and turned the truck off then on and the gauges came back but transmission was still not right. When I shifted the transmission into second the speedometer/tachometer/gear indicator all quit working again.

I have an appointment at the shop tonight. I will suggest they consider the ignition switch, although not quite sure if it is the same.

Thanks.
Was this
answer
helpful?
Yes
No
+4
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
TINO9
  • MEMBER
There is a little white plastic box located behind the glove box. This unit controls the speedometer in the dash, that might be affecting shifting. Try going to the salvage yard to find a replacement part.
Was this
answer
helpful?
Yes
No
+1
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
KEN
  • ADMIN
Hey,

Great addition to this thread! Please feel free to help out on the site whenever it can add information that will help.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+1
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
DANSHARP2
  • MEMBER
  • 1995 CHEVROLET TRUCK
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 13,500 MILES
Six cylinder two wheel drive automatic 135,000 miles

The tachometer and the speedometer stopped working on my truck, and the transmission does not shift. It starts and stays in third gear. I was told to check the fuses and they were alright.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
JACK42
  • MEMBER
Could be a problem with the VSS (vehicle speed sensor) if the PCM does not see the truck moving it will not let the transmission operate properly.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
TIM7532
  • MEMBER
  • 1995 CHEVROLET TRUCK
  • 5.7L
  • V8
  • 4WD
  • AUTOMATIC
  • 160,000 MILES
Will not shift into overdrive.
Was this
answer
helpful?
Yes
No
-1
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
HMAC300
  • EXPERT
Scan for codes it may be torque converter or a bad clutch. So best to have a transmission professional give an opinion on this.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
COOKEM
  • MEMBER
  • 1991 CHEVROLET TRUCK
  • 7.6L
  • V8
  • 2WD
  • AUTOMATIC
  • 250,000 MILES
I just recently put a big block 454 in my truck and did away with all the electronics, now when I drive it my transmission is winding way out and shifting real hard. It acts like the old transmission vacuum module is not hooked up, but my transmission does not have one. What do you think the problem is?

Thanks.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
WRENCHTECH
  • EXPERT
These are the kinds of things that happen when you try to Frankenstein a computer controlled car. You create a whole set of new problems. You have an operating system for one thing and now you have something else. All I can advise you to do is find an old Turbo 400 and then you are going to have to custom make mountings and driveshaft.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
CARRIERJ
  • MEMBER
  • 1991 CHEVROLET TRUCK
V8 four wheel drive automatic 105,000 miles.

Rear end was recently replaced with new differential, ring and pinion. After rear end work was completed, transmission will not go into gear and go forward when placed into drive. Will work in reverse, and placing into first gear manually, but will barely want to move in drive. All fluid levels good, transmission was rebuilt about one year ago and has always worked properly prior to rear end change. Yoke seal at drive shaft was replaced also when leak was noticed while doing rear end work.
Was this
answer
helpful?
Yes
No
-1
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
MERLIN2021
  • EXPERT
Raise the rear wheels off the ground and try to spin the wheels. Sounds like somethings not right (locked up) in the rear end gears.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
94CHEVYZ71
  • MEMBER
  • 1994 CHEVROLET TRUCK
  • V8
  • 4WD
  • AUTOMATIC
  • 198,000 MILES
V8 four wheel drive automatic 198,000 miles.

I have a K1500 Z71 extended cab it has a 4l60e and the transmission will not shift and the speedometer will not work. The day it happened I got under the truck and found the wire harness for the transmission sitting on the front driveshaft, it did not pull the wires it had just chewed them up. So I put them back together and now the transmission will not shift and the speedometer will not work. I have checked every fuse under the dashboard and I have changed the ignition switch under the dash. Please help this thing is driving me crazy.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
DOCFIXIT
  • EXPERT
Hi,
That was your wiring to vehicle speed sensor any damage to wiring not good. Also, how did it come off VSS? VSS must be faulty and/ or wiring because no speedometer and no shift.
Let me know.
Thanks for the donation.
Was this
answer
helpful?
Yes
No
Friday, May 5th, 2017 AT 12:43 PM (Merged)
Tiny
WALTER BARNES SR.
  • MEMBER
  • 1996 CHEVROLET TRUCK
  • 2WD
  • AUTOMATIC
  • 1,834,616 MILES
Will not shift first, second and third.
Was this
answer
helpful?
Yes
No
+2
Friday, May 5th, 2017 AT 12:45 PM (Merged)
Tiny
KEN
  • ADMIN
Does the transmission not go into gear? Do you have reverse?

Best, Ken
Was this
answer
helpful?
Yes
No
+1
Friday, May 5th, 2017 AT 12:45 PM (Merged)

Please login or register to post a reply.

Recommended Guides