1968 C-10 Turn signal question

Tiny
SOBA_03
  • MEMBER
  • 1968 CHEVROLET TRUCK
Rear turn signals work perfectly, Fronts both blink. I have replaced bulbs, Cleaned and reterminated all grounds. Flashers work and all 4 blink. Up front both flash together.

I have traced all wiring and nothing has been spliced in and everything is was still in the black tape wrap and plastic loom. Nothing appears to be corroded and all the sockets are A OK no signs of corrosion.

I did try and swap out flasher with the emergency flasher but I don't think that the 2 are interchangable, didn't work at all when I did that put them back in original configuration and we are back to both flashing.

Any help would be great. The flasher installed doesn't indicate typical signs of failure. Everything seems normal. Normal flash rate.

Thanks!
Do you
have the same problem?
Yes
No
Wednesday, September 5th, 2007 AT 1:41 PM

2 Replies

Tiny
MERLIN2021
  • EXPERT
So the problem about the blinkers is they blink? Or the right blinks when you only want the left? And vice versa? I would try the flasher replacement first cause next is the switch! Or wires shorted together.
Was this
answer
helpful?
Yes
No
Wednesday, September 5th, 2007 AT 4:26 PM
Tiny
SOBA_03
  • MEMBER
Yes, the problem when I use either the left or the right turn signal, both of the front signals blink no matter what side I try to use, IE left or right.
Was this
answer
helpful?
Yes
No
Wednesday, September 5th, 2007 AT 8:37 PM

Please login or register to post a reply.

Recommended Guides