Fuel pump replacement?

Tiny
HANSIL08
  • MEMBER
  • 2002 CHEVROLET SILVERADO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 101 MILES
Where is fuel pump located and how to I know for sure it is malfunctioning?
Do you
have the same problem?
Yes
No
Tuesday, May 26th, 2009 AT 12:42 PM

30 Replies

Tiny
JDL
  • EXPERT
Hello, get a fuel pressure gauge and check fuel pressure for a start. Fuel pressure spec shows 58-64.

Here is how you change the pump and its location in the diagrams below. Check out the diagrams (Below). Please let us know if you need anything else to get the problem fixed.
Was this
answer
helpful?
Yes
No
+1
Monday, March 4th, 2019 AT 7:07 PM
Tiny
FRANKMAC1966
  • MEMBER
  • 2002 CHEVROLET SILVERADO
2002 Chevy Silverado V8 Automatic 112, 00 miles

I have installed a new fuel pump, still won't start, checked fuses, have fuel, where is the oil pressure switch?
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
2CEXPT
  • MEMBER
When you 1st turn key to run -Do you hear the fuel pump come On? If so check fuel pressure and then comeback with your readings this is where we start.
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
FRANKMAC1966
  • MEMBER
No. Do not hear pump.
Was this
answer
helpful?
Yes
No
+1
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
2CEXPT
  • MEMBER
Inspect and test the fuel pump fuse and the fuel pump relay then comeback
Was this
answer
helpful?
Yes
No
+1
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
FRANKMAC1966
  • MEMBER
Aready checked fuses and relays. Is there anything under the truck I can check.
Was this
answer
helpful?
Yes
No
+1
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
DSULTEME
  • MEMBER
  • 2002 CHEVROLET SILVERADO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 95,000 MILES
Hi, I have a 2002 Silverado... I've replaced my fuel pump, fuel filter, spark plugs, wires, and distributor.
Now I'm having multiple misfires and sputtering, but only when the weather and engine are cold. I am having engine hesitations from about 1700 to 2100 rpms. It runs fine at higher rpms.
It idles fine but if the engine is cold and I turn the wheel left or right when the vehicle is in drive at a stop it'll die.
I have seafoamed it trying to clean the injectors but that didn't work either.
Thank you for your time and ideas!
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
2CEXPT
  • MEMBER
If you don't hear the fuel pump and the fuse and relay is okay-its coming from the computer fuel pump relay control
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
02REDCAMARO
  • MEMBER
Sounds like you have an ignition problem. Plugs, wires, coils, crank trigger sensor, and all wiring harness connections need to be checked. I just had to replace all of my coils, they failed after the engine ran too lot for too long.
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
QUAGMIRE86
  • MEMBER
Sounds alot like the issue I was having with mine. Replaced many things and still had the issue. Finally found that the MAF sensor was bad.
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
BIGDENNIS123
  • MEMBER
  • 2002 CHEVROLET SILVERADO
  • 4.3L
  • V6
  • 2WD
  • AUTOMATIC
  • 141,000 MILES
I just recently put in two new fuel pumps into my truck. Then yesterday when I went to turn on my truck I started it and shut my door then it died. I can't seem to find what the problem is then today it will stay on. The first pump I put in was a ac delco one I bought off of eBay and that lasted me about a few months. This next one I just put in was a airtex and didn't last me but 3 weeks. I keep thinking I have and electrical problem or many it's the injectors. I'm thinking about puting some injector cleaner in my tank and seeing if that helps. Also, my batter is about 3 to 4 years old. Also, the fuel pump had a louder noise to it then it does now when turning the key to on position. Please help!
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
HAve you checked to see if the fuel pump pressure is within the manufacturer's specs? Also, if the battery is starting the truck without issue, it should be fine.
Was this
answer
helpful?
Yes
No
-1
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
BIGDENNIS123
  • MEMBER
How would I go about checking that? I assumed all these pumps were pretty much universal
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Here is a video for testing. It is being done on a Tahoe, so it should be very similar to your vehicle.

https://www.2carpros.com/articles/testing-a-fuel-pump-and-pressure-regulator-video

Tell me, did you get the fuel pump designed for your vehicle and install it in the fuel tank?
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
VICKIAYALA
  • MEMBER
  • 2002 CHEVROLET SILVERADO
  • 170,000 MILES
I replaced the fuel pump on a 2002 chevy 1500 4.3 p/u, ran great parked it the next morning would not start. Put new fuel filter cleaned trottle body, next morning started up. Drove that day off & on drove 20 miles to put tires on it then it wouldn't start at the tire shop. Towed it home. No fuel pressure at all, power is getting to the wires going into the blk sensor on top of the pumper, but no power from the other wires going to the other connector on top of the pump. Is there a fuse to ck to these wires going to the pump. Or is there something else I need to do? Please help, thank you Vicki
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
SATURNTECH9
  • MEMBER
So you have power going to the fuel pressure sensor on top of the fuel pump module?But no power the fuel pump connector itself?
Was this
answer
helpful?
Yes
No
-2
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
VICKIAYALA
  • MEMBER
There are two electric plug on top of the 2002 chevy fuel pump. One is a black sensor that pops off and the other is cream color. The wires going to the blk one, I put a test light and there is power to the gray wire. But the other wire plug in is blue and none of the four wires have power coming from them. And I tested them with the truck key turned ON. I pulled the fuel line from the pump to the fuel filter turned on the key no fuel. No pressure coming out the port by the trottle body. But my questions is; doesn't there have to be power coming into both those plug wires to the pump. Is there a fuse, besides the fuel pump relay? The relay is working with the test light.
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
SATURNTECH9
  • MEMBER
The one you have power to is the fuel pressure sensor which is normal. Your only going to have power to the other connector which goes the fuel pump and fuel sending unit for the first couple of seconds with the key in the run position. Unless the engine is running. You will have to have someone crank the engine while checking for power at that connector. What model silverado do you have 1500 etc?Also what size engine do you have?
Was this
answer
helpful?
Yes
No
-1
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
VICKIAYALA
  • MEMBER
It is a 1500 4.3L short bed automatic TWD
Was this
answer
helpful?
Yes
No
+1
Friday, June 26th, 2020 AT 12:44 PM (Merged)
Tiny
SATURNTECH9
  • MEMBER
For the 4.3 I need the 8th digit of the vin they have two different 4.3 for that truck.
Was this
answer
helpful?
Yes
No
Friday, June 26th, 2020 AT 12:44 PM (Merged)

Please login or register to post a reply.

Sponsored links