2001 CHEVY SILVERADO ENGINE LOOSES POWER AND SURGES

  • Tiny
  • Russell And Angela
  • 2001 CHEVROLET SILVERADO

Engine Performance problem
2001 Chevy Silverado V8 Four Wheel Drive Automatic 167000 miles

Runs great 99% of the time. It will loose power, surge intermediately and after a few minutes will regain steady power. It has done this after start up as well as after warmed up and running. Also ABS and E Brake indicator lights will stay on occasionally until ignition is turned back off. Could this be a fuel filter or pump problem? Or is it electrical? Any suggestions on troubleshooting would be appreciated!

Do you
have the same problem?
Yes
No
Tuesday, September 8th, 2009 AT 9:36 PM

5 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Dirty fuel injectors (cleaning the injectors often fixes this).
Bad MAP (manifold absolute pressure) sensor
Bad TPS (throttle position) sensor
Bad or dirty MAF (mass airflow) sensor
Low fuel pressure (leaky fuel pressure regulator or weak fuel pump)
Vacuum leaks (intake manifold, vacuum hoses, throttle body, EGR valve)
Bad gasoline (fuel contaminated with water or too much alcohol)

Sometimes, what feels like a hesitation is actually ignition misfire rather than lean misfire. The causes of ignition misfire may include:

Dirty or worn spark plugs
Bad plug wires
Weak ignition coil
Wet plug wires

Was this
answer
helpful?
Yes
No
Wednesday, September 9th, 2009 AT 12:41 AM
  • Tiny
  • Quagmire86
  • MEMBER

The loss of power and surging when cold and hot is something I'm dealing with too (haven't figured it out yet). As far as the ABS and E-brake problem you have. Is it just the lights on you dash that light up or is you ABS actually activating? I had a situation where, on dry pavement, when coming to a stop the ABS would activate. It was simply that rust between the wheel bearing and the ABS sensor was pushing the sensor "Out of range" from the toothed wheel. I cleaned the rust off of the wheel cylinder and bolted the sensor back into the hole. Problem solved.

Was this
answer
helpful?
Yes
No
Wednesday, September 9th, 2009 AT 10:58 PM
  • Tiny
  • Strawman1988
  • MEMBER

Having same issue e brake light and abs similar mileage did you remedy your issue if so please help at wits end

Was this
answer
helpful?
Yes
No
Tuesday, October 13th, 2009 AT 12:12 AM
  • Tiny
  • Strawman1988
  • MEMBER

Having same issue as you including e brake and abs lights mileage almost exactly the same if anyone has remedied this please help replace everything but fuelpump and ecm at wits end

Was this
answer
helpful?
Yes
No
Tuesday, October 13th, 2009 AT 12:17 AM
  • Tiny
  • Quagmire86
  • MEMBER

I found the problem to my loss of power/surging. It was a bad MAF sensor. Now it runs great and the fuel mileage is impoved too. As far as your problem with the ABS/E-brake, not sure what it is.

Was this
answer
helpful?
Yes
No
Tuesday, October 13th, 2009 AT 8:07 AM

Please login or register to post a reply.

Other Engine Surge Questions