1998 Chevy Silverado Fuel System

Tiny
EEINEED
  • MEMBER
  • 1998 CHEVROLET SILVERADO
  • V8
  • 2WD
  • AUTOMATIC
  • 169,400 MILES
Is there a sensor or any thing that prevents the electric fuel pump from running?
Do you
have the same problem?
Yes
No
Tuesday, December 4th, 2007 AT 2:11 PM

7 Replies

Tiny
RASMATAZ
  • MEMBER
Inspect and test the ECM B fuse and Fuel Pump Relay if its okay see fuel pump circuit below


http://www.2carpros.com/forum/automotive_pictures/12900_ecmb_and_fuel_pump_relay_1.jpg




http://www.2carpros.com/forum/automotive_pictures/12900_oil_sending_unit_and_fuel_pump_circuit_20.gif



www.eautorepair.net
Was this
answer
helpful?
Yes
No
+1
Tuesday, December 4th, 2007 AT 2:36 PM
Tiny
EEINEED
  • MEMBER
Thanks for your help!
But I just replaced the fuel pump and the relay and the fuel filter. It ran fine for a week and now it does
not start. What else can I check?
Was this
answer
helpful?
Yes
No
Tuesday, December 4th, 2007 AT 2:56 PM
Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure-that checks out. Disconnect a plug wire and ground it to the engine crank engine over-do you have spark-if so this time crank engine over again and listen to the fuel injector/s are they clicking-if not you won't get fuel cuz the injector/s are not pulsing meaning its not opening and closing=No fuel.
Was this
answer
helpful?
Yes
No
Tuesday, December 4th, 2007 AT 3:38 PM
Tiny
EEINEED
  • MEMBER
I do not here any clicking, so what could be wrong with the fuel injectors?
Was this
answer
helpful?
Yes
No
Tuesday, December 4th, 2007 AT 3:49 PM
Tiny
RASMATAZ
  • MEMBER
Do you have spark-If so get a noid light from the parts store and hook up on the injector harness is the light blinking if not-you have a problem with computer injector driver.

Am gonna ask again do you have spark-this is critical. No spark could be the CMH/CPS sensors. The computer has to have an ignition reference input signal in order for it to energize the injector/s.
Was this
answer
helpful?
Yes
No
Tuesday, December 4th, 2007 AT 4:10 PM
Tiny
EEINEED
  • MEMBER
Yes, I do have a blue spark from the plug wire to ground.
Was this
answer
helpful?
Yes
No
Wednesday, December 5th, 2007 AT 7:05 AM
Tiny
RASMATAZ
  • MEMBER
You got spark-do a fuel pressure check-don't take it for granted that the pump is working because its coming On or whatever. Fuel is missing unless the valve and ignition timing is way off.
Was this
answer
helpful?
Yes
No
Wednesday, December 5th, 2007 AT 12:44 PM

Please login or register to post a reply.

Recommended Guides