1993 Chevy S-10 Idle Issues

Tiny
MONTICELLOROB
  • MEMBER
  • 1993 CHEVROLET S-10
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 188,000 MILES
I just made a small donation. I just got a 1993 S10 V6, engine code "Z, " from a friend. He said it was running fine until his hired help steam cleaned the engine. After that, gas had to be poured into the intake for it to crank, then it idled very high.

I replaced the MAF sensor. It then would crank on its own. However, it still idled very high. I then changed the Idle air control valve. It idles at a normal rpm now but two different mechanics have said it is idling rich as evidenced by the black smoke that is produced from the tail pipe. Also, it does not idle very smoothly.

Any suggestions? From what I have read, this is not an uncommon problem with this engine.

Thanks
Do you
have the same problem?
Yes
No
Monday, February 25th, 2008 AT 8:36 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
What do you have here-is it a Vortec 4.3 with the spider IMTV system or TBI

Have you checked the fuel pressure, if so what was the reading in KOEO?
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2008 AT 12:03 AM
Tiny
MONTICELLOROB
  • MEMBER
Mine is TBI. High Idle, replaced MAF and IAC vlave. Idles normally but rich (black smoke)
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2008 AT 8:06 AM
Tiny
RASMATAZ
  • MEMBER
Idles normally but rich (black smoke)
Check the fuel pressure/test the coolant temperature and throttle position sensors/injectors and fuel pressure regulator.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2008 AT 3:29 PM

Please login or register to post a reply.

Recommended Guides