1987 Chevy S-10 Pickup Coil?

Tiny
BISAACS
  • MEMBER
  • 1987 CHEVROLET S-10
Engine Performance problem
1987 Chevy S-10 6 cyl Two Wheel Drive Automatic

1987 Chevy Blazer Vortec 4.3 engine.

Replaced: distributor cap, plugs, plug wires, coil.

Runs rough when in gear, but idles fairly smoothly and revs well with tranny in park. Sometimes blows a bit of black smoke. I can smell unburned fuel heavily in the exhaust.

Is this a pickup coil issue?
Do you
have the same problem?
Yes
No
Sunday, June 6th, 2010 AT 10:16 AM

3 Replies

Tiny
BLACKOP555
  • EXPERT
Do you have electrical, vaccum or mechanical spark advance?
Was this
answer
helpful?
Yes
No
Sunday, June 6th, 2010 AT 1:49 PM
Tiny
BISAACS
  • MEMBER
I need to correct some information. It is a '92 with a CBI vortec. When I read the engine error code, it came up "43".

The advance is electrical, near as I can tell.
Was this
answer
helpful?
Yes
No
Sunday, June 6th, 2010 AT 3:34 PM
Tiny
BLACKOP555
  • EXPERT
That is a code for a knock sensor issue.

First thing to do is check the wiring harness goign to the knock sensor. Make sure the connection is not coroded and its tight. Also check the wiring harness near it for signs of damage.

Next thing you can do is take the sensor out and hook up a volt meter to it then tap the end of it. Should produce a voltage. If no voltage coming out of it its bad. Or if its constantly making a voltage it would be bad.

Disconnect knock sensor and try running vehicle. Run better now?
Was this
answer
helpful?
Yes
No
Sunday, June 6th, 2010 AT 5:30 PM

Please login or register to post a reply.

Sponsored links