Chevy 1991 S-10 No heat

Tiny
JSMALL
  • MEMBER
  • 1991 CHEVROLET
I have replaced the thermostat and heater core. The water pump is working. The bypass hose that comes out of the engine and goes into the heater core gets water but it is not warm. The water coming out of the top raditor hose is warm. I have flused and refilled to get the air out. Doesn't seem like the water pressure to the core is that strong either. Please help! Please donate like I did!
Do you
have the same problem?
Yes
No
Monday, February 12th, 2007 AT 6:39 PM

6 Replies

Tiny
JACK42
  • MEMBER
What temp t-stat did you use? Should be a 195 degreee. Do you hear alot of fan noise, check to be sure the clutch fan isnt locked up. Does that truck have the plug in heater hose fitting? If a regular fitting witout a restrictor was used in the manifold then the engine and heater wont run as warm
Was this
answer
helpful?
Yes
No
Tuesday, February 13th, 2007 AT 7:39 AM
Tiny
JSMALL
  • MEMBER
I did use a 195 thermostat. The fan seems to kick on fine without excessive noise. I'm not sure what you mean by a plug in the heater hose so I'm assuming it doesn't. The hose from the engine is a threaded nut and metal pipe that turns into a rubber hose via a permenant coupling. Again, it seems odd that there's not alot of pressure in that hose either but I don't know enough to say for sure. Thank you!
Was this
answer
helpful?
Yes
No
Tuesday, February 13th, 2007 AT 9:22 AM
Tiny
JACK42
  • MEMBER
Does the engine run at normal temp?
Was this
answer
helpful?
Yes
No
Wednesday, February 14th, 2007 AT 9:56 AM
Tiny
JSMALL
  • MEMBER
Yes. I don't know if this is related. But the oil pressure is always high when the truck is running. Except when I come to a full stop then it will lower and pulse and a normal range. When I press on the accelerator is goes back up and stays there.
Was this
answer
helpful?
Yes
No
Thursday, February 15th, 2007 AT 2:11 PM
Tiny
JACK42
  • MEMBER
So the engine runs at normal temp (around 200) but the water going from engine to heater core isnt hot. Has any engine work been done?
Was this
answer
helpful?
Yes
No
Thursday, February 15th, 2007 AT 4:23 PM
Tiny
JSMALL
  • MEMBER
I just purchased this vehicle from a fly by night dealer. I thought they were more legit and they told me that they would fix the heater if I bought it. A week later they totally closed up shop. I still haven't even got my title. Wish me luck on that. Thereofre I'm not sure if any engine work has been done. I'm sure the dealer didn't do anything to it. I'll take off the returns and try to check it that way. We just got another few inches of snow last night so I may wait a day or so. Thank you all!
Was this
answer
helpful?
Yes
No
Saturday, February 17th, 2007 AT 9:26 AM

Please login or register to post a reply.

Recommended Guides