2004 Chevy Monte Carlo Speedometer

Tiny
KELLER44
  • MEMBER
  • 2004 CHEVROLET MONTE CARLO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 60,000 MILES
Recently my speedometer has gone completely out of whack. Its has reached over 120 when I'm going about 30, and at that time when I stopped it would go down to about 70. Right now its parked and stopped at about 50. Not sure if this is a fuse problem, cluster problem or what it might be.
Do you
have the same problem?
Yes
No
Friday, January 30th, 2009 AT 4:07 PM

5 Replies

Tiny
DOCFIXIT
  • EXPERT
Check engine light on? Any problem trans shifting? If no to both then speedo head problem.
Was this
answer
helpful?
Yes
No
Friday, January 30th, 2009 AT 4:10 PM
Tiny
KELLER44
  • MEMBER
No to both, also noticed that the background lights to the speedometer and the others to not be working, but the lights that show me if i'm in drive or park are working fine
Was this
answer
helpful?
Yes
No
+1
Friday, January 30th, 2009 AT 7:39 PM
Tiny
MYKJAK
  • MEMBER
I had the same problem a year ago. The entire instrument cluster had to be replaced
Was this
answer
helpful?
Yes
No
+1
Saturday, January 31st, 2009 AT 3:12 PM
Tiny
COASTER2U
  • MEMBER
It is your cluster, the gears in them are cheap and they break. You can buy a new one from the dealer-($$ expensive)or remove the old one and get it repaired which is much cheaper
I am in the same boat as we speak and am trying to find out how to remove the cluster if anyone happens to know?
Was this
answer
helpful?
Yes
No
Saturday, June 20th, 2009 AT 4:27 PM
Tiny
COASTER2U
  • MEMBER
Thanks for the reply, but I have found a repair place in Canada at the same price
Was this
answer
helpful?
Yes
No
Wednesday, July 29th, 2009 AT 5:44 AM

Please login or register to post a reply.

Recommended Guides