1990 Chevy Lumina Euro 3.1

Tiny
TAPEWORM
  • MEMBER
  • 1990 CHEVROLET LUMINA
Automatic, front wheel drive, v6, 66k miles

My question involves several symptions all at once. First this "service engine soon" light came on while I was on the road that caused no immediate problems. Second about an hour later the car decided it no longer need power steering fluid and dumped it all on the road. That was taken care of very quickly due to a convienent gas station and has not leaked since then although the location of the leak has yet to be found. It left a neat little 2 or 3 inch wide line from front to back on the inside of the hood of steering fluid. Lastly the car now has a noticeable off-line stumble that might have something to do with a miss at idle and when held steady at about 2000rpm. Now so far I have already checked the codes and only gotten a code "12" which as far as I can tell means nothing really. Also I hooked up a Snap-On scanner to the car which said it couldnt not find the computer at all. Please any information on any of these problems would be appreciated. Thanks, Greg
Do you
have the same problem?
Yes
No
Monday, August 6th, 2007 AT 3:11 PM

6 Replies

Tiny
NICKN
  • MEMBER
When was the last time u had a tune-up done on this vehicle?
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2007 AT 8:43 PM
Tiny
TAPEWORM
  • MEMBER
Well the last time I really had a tune-up was 2000 miles ago and I did oil change, oil filter, coolant change, coolant temp sensor, thermostat, air filter, spark plugs, plug wires and I put in some fuel injector cleaner

also all the problems I described happened within a 2 hour time frame if you feel that ive left out any information that could help please feel free to e-mail me
Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2007 AT 2:50 PM
Tiny
TAPEWORM
  • MEMBER
Placing shifter in 1st gear at idle causes constant grinding noise from trans. Along with all the other issues thus far. Any thoughts?
Was this
answer
helpful?
Yes
No
Friday, August 17th, 2007 AT 2:25 PM
Tiny
NICKN
  • MEMBER
I would have ur transmission looked at, it may need a fluid and filter change, or worse. U dont really know untill u have that problem looked into.
Was this
answer
helpful?
Yes
No
Tuesday, August 21st, 2007 AT 3:19 PM
Tiny
TAPEWORM
  • MEMBER
Heres a question to go with my question. Could all of my problems be cause by a fubared TCC in the trans? While talking with my brother he mentioned the fact that the car almost feels like its torque converter is always locked up and is running 1to1 in first gear which is why stabbing the throttle off the line no longer rips the tires loose but just kinda rolls off the line for the first 50 feet or so then it really hauls like its supposed to
Was this
answer
helpful?
Yes
No
Saturday, September 1st, 2007 AT 11:40 AM
Tiny
NICKN
  • MEMBER
Very good possibility
Was this
answer
helpful?
Yes
No
Tuesday, September 4th, 2007 AT 9:44 PM

Please login or register to post a reply.

Recommended Guides