Fuel Gauge amp Temp Gauge will not work

Tiny
CLEECOM
  • CHEVROLET IMPALA

2004 chevy impala 3.4 sedan with 63k miles. I bought the car and did not notice the fuel gauge and the temp gauge are not responding; though the speedometer is working fine. The vehicle also had an after market radio and the factory radio was plugged in but placed in the trunk. It is also locked. I had the dealer install some sort of adapter to eliminate the factory radio so the comp will read the after market as its main head unit. How can I get the fuel gauge and the temp gauge to work? Thanks

Do you
have the same problem?
Yes
No
Friday, August 24th, 2007 AT 9:27 PM

3 Replies

Tiny
M_H_RITZEL
  • EXPERT
  • 2,770 POSTS

I may be wrong but the wiring I saw, the radio does not hook up to the computer, the one in the back trunk is the amplifier. As far as the fuel and temp guage, had the after market radio been fused into the fuse for the instrament panel fuse.

Was this
answer
helpful?
Yes
No
Friday, August 24th, 2007 AT 10:27 PM
Tiny
CHRISTIEE
  • MEMBER

I have the same problem, but my speedometer is not working either. And the the light for the P/N/D stuff.

Was this
answer
helpful?
Yes
No
Monday, August 27th, 2007 AT 11:00 AM
Tiny
M_H_RITZEL
  • EXPERT
  • 2,770 POSTS

Check the grounds. Try adding a extra ground from the negative side of the battery to the frame, Not to good with computers but have seen with a ground problem it would mess up everything.

Was this
answer
helpful?
Yes
No
Thursday, August 30th, 2007 AT 3:07 PM

Please login or register to post a reply.

Other Instrument Cluster Gauge Engine Temperature Not Working Questions