2001 Chevy Impala Temp Gauge and A/C Do Not Work on Occassi

Tiny
JARHEAD95
  • MEMBER
  • 2001 CHEVROLET IMPALA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 97,000 MILES
Recently, my temp gauge stop working while I was driving and now, will come on and go off randomly. I read something on the net where other people have had the problem where the a/c does not work when the temp gauge does not work. I tried that when the temp gauge did not work and sure enough, the a/c did not work either. The blower worked but it did not get cold. I recently had the coolant flushed and replaced with green instead of dex-cool but the dealer said that would have nothing to do with it. Also, my air bag light stays on all the time and my back dome lights do not work. Sorry if you have answered any of these questions before.

Thanks-
Tim
Do you
have the same problem?
Yes
No
Thursday, October 23rd, 2008 AT 1:51 PM

2 Replies

Tiny
RHALL77
  • MEMBER
I would have the vehicle scanned to see if there is any codes and see if the pcm is reading the temp sensor. It may be just a cluster
Was this
answer
helpful?
Yes
No
+1
Thursday, October 23rd, 2008 AT 3:35 PM
Tiny
JARHEAD95
  • MEMBER
This was a long time ago but the problem turned out to be the thermostat. I changed it and the temp gauge started working and the a/c worked as well as the fan stopped running all of the time. Apparently, this is a safe-guard when the thermo goes out on an Impala.
Was this
answer
helpful?
Yes
No
+2
Thursday, November 12th, 2009 AT 12:47 PM

Please login or register to post a reply.

Recommended Guides