2006 Chevy Impala I HATE CARS!

Tiny
MATTMACD1
  • MEMBER
  • 2006 CHEVROLET IMPALA
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 72,000 MILES
Hi my mane is Matt MacDougall and I own a, well you know what I own, I just filled in that info. Anyway, I have been having some trouble with the tach surging. The traction control light comes on and the check engine light comes on. The check engine light doen't come on every time the traction control lights comes on though. When I turn the car off the traction control light doesn't come back on. I don't know if this has anything to do with the surging. I had the camshaft actuator replaced and that did the trick for a while. About 2000 miles or so. Now it has started to surg again. I know that the codes that come up are p0011 and when the check engine light came on a while back code p0842 came on as well. I am hoping that you can fill me in on my next plan of attack. I am from upstate NY and drove to CA and I have to get back. Thanks for your time.

Matt
Do you
have the same problem?
Yes
No
Tuesday, November 10th, 2009 AT 5:51 PM

1 Reply

Tiny
BRIAN 1
  • MEMBER
P0011: Camshaft Position (CMP) System Performance, first check the oil level, Ensure that the vehicle has the correct engine oil and is not old, burnt or contains additives. If the vehicle has the incorrect engine oil, is old, burnt, or contains additives then change the oil and filter. Test the engine oil pressure for correct operation. If checking all the above is fine, you will be looking at a camshaft actuator.
Was this
answer
helpful?
Yes
No
Wednesday, November 11th, 2009 AT 5:51 PM

Please login or register to post a reply.

Recommended Guides