Hard Shifting

Tiny
CAVYSPORT
  • MEMBER
  • 2002 CHEVROLET CAVALIER
Transmission problem 4 cyl Front Wheel Drive Automatic 140000 miles

I recently had my car serviced for hard shifting. Basically the fix was resetting the computer and that solved the problem. Now it's a month later and it is doing the same thing only this time it comes and goes. I'll unhook the battery to reset the computer and it'll be fine for about 15 miles then the trac off light comes on and it shifts hard. Drive another 15 miles and it's back to normal. What causes this? Is it a sensor that is going bad? If so which one is it?

P0113 is the code. This refer's to the IAT sensor. This is exactly what I had replaced about a month ago. So I bought a new one this evening and by the time I got home the check engine light and trac off light went off and as soon as I put the car in park the trac light came on. Could this be something else? Another thing I noticed is when driving at about 1500 RPM it fluctuates up and down.
Do you
have the same problem?
Yes
No
Monday, August 17th, 2009 AT 12:25 PM

7 Replies

Tiny
JACK42
  • MEMBER
Are you clearing the code before driving it?The PCM needs to be cleared first so that if the light comes back on you can scan it again to see what the issue is. The Trac light may be an ABS issue, have that system scanned as well.
Was this
answer
helpful?
Yes
No
-1
Wednesday, August 19th, 2009 AT 7:36 AM
Tiny
CAVYSPORT
  • MEMBER
Cleared the code. Check Engine light and Trac Off light came back on and it threw up the same P0113 code. Possible bad connector?
Was this
answer
helpful?
Yes
No
-1
Wednesday, August 26th, 2009 AT 6:43 AM
Tiny
JACK42
  • MEMBER
Possibly. Might need to do a pin to pin check from the connector to the PCM to verify the wires are good as well. Is this a2.2L or a 2.4 L?
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 7:37 AM
Tiny
CAVYSPORT
  • MEMBER
2.2L ECOTEC.
Was this
answer
helpful?
Yes
No
Wednesday, August 26th, 2009 AT 1:17 PM
Tiny
WINSE
  • MEMBER
I am having the same issue. Hard shifting with error code P0113 on my 2.2L 2002 cavalier. I don't think the IAT sensor itself is the problem though it may be the wiring to the IAT. I assume that there is an electrical problem somewhere that causing the error code and messing with the power in a way that disturbs the function of the automatic transmission. Any ideas?
Was this
answer
helpful?
Yes
No
Wednesday, April 8th, 2015 AT 7:38 AM
Tiny
WINSE
  • MEMBER
Additionally at one point I was regularly having this issue which progressively got worse until when I came to a stop the TCC solenoid would not disengage. I replaced the TCC solenoid and everything worked perfectly for about 8 months. I'm wondering if it had to do with the transmission fluid temperature as it was fall/winter as well.
Was this
answer
helpful?
Yes
No
Wednesday, April 8th, 2015 AT 7:41 AM
Tiny
KEN
  • ADMIN
Hello,

If I can put my 2 cents in here. It sounds like you may have a partially plugged catalytic converter causing the vacuum to drop making the transmission shift hard. I would do this check on the converter to see if that your problem.

https://www.2carpros.com/articles/how-to-test-a-catalytic-converter

Please run this test and get back to us so we can continue helping you.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+2
Monday, May 8th, 2017 AT 6:26 PM

Please login or register to post a reply.

Recommended Guides