1998 Chevy Cavalier Engine Rebuild

Tiny
CURTIS2930
  • MEMBER
  • 1998 CHEVROLET CAVALIER
  • 4 CYL
  • FWD
  • MANUAL
  • 112,000 MILES
To make a long story short- I recently replaced pistons-Head-Wtr pump-
Started up for first time last night-
It turned over fine but it was shaking- no to bad
but bad enough- We were very carefull when we taking off and reinstalling the balancer-
But its shaking as if its not balanced-?
Could it be something in Crank Pully?
the only other thing I can think of-is that maybe we
got the Cam sprokets were switched?
Intake and exhaust?
Please help
Any tuning ideas that would smooth the motor up.
Do you
have the same problem?
Yes
No
Thursday, April 2nd, 2009 AT 10:32 AM

6 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
Did you replace plugs, wires? As far as the cam pulley, I don't think that would cause the problem.

Joe
Was this
answer
helpful?
Yes
No
Friday, April 3rd, 2009 AT 6:30 PM
Tiny
CURTIS2930
  • MEMBER
I did replace all plugs and Wires
I was reading a earlier question
It was in reguards to rough idleing
Sounds like my situation
We first thought it was a vacuum problem
But-I though this was a zero clearance motor
Any little bit would possibly break valves
Thats how I got into this predicament
Changing a Water pump- and must have turned crank off of tdc
could it be 1 tooth off- or a link off
that could be causing to idle rough
Was this
answer
helpful?
Yes
No
Monday, April 6th, 2009 AT 5:01 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If you are a tooth off, that would cause a problem. If you are not 100% sure, (and I hate to say it), you may want to recheck.
Was this
answer
helpful?
Yes
No
Tuesday, April 7th, 2009 AT 10:45 AM
Tiny
CURTIS2930
  • MEMBER
Hooked to the OBDII on it
see wht kind of reading we would get
It came up with P0303 MIsfire in third cylinder
Changed connector to second cylinder
Rechecked code- it then came up p0300
All wires and plugs are new- Could it be the Ing Module-read that they fail on occasion
Only other thing im thinking of is that we didnt replace EGR gasket-and seems like we are getting a small exhaust leak near exhaust manifold-so I will replace both gaskets tonight- Sounds good but runs rough at low idle
once you give it some rpm it smooths out
I think we are narrowing it down- Thanks for all of your advise
Curtis
Was this
answer
helpful?
Yes
No
Tuesday, April 7th, 2009 AT 10:57 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
An Egr leak can cause this. Let me know what you find.
Was this
answer
helpful?
Yes
No
Tuesday, April 7th, 2009 AT 11:00 AM
Tiny
CURTIS2930
  • MEMBER
I will do
thanks
Again
Curtis
Was this
answer
helpful?
Yes
No
Tuesday, April 7th, 2009 AT 11:31 AM

Please login or register to post a reply.

Recommended Guides