96 Chevy Blazer transmission problems

Tiny
JAY62078
  • MEMBER
  • 1996 CHEVROLET BLAZER
I HAVE A 96 CHEVY BLAZER 4.3L WITH 100,000+ MILES AUTOMATIC TRANSMISSION, 4 WHEEL DRIVE, IT'S NOT MAKING ANY SOUNDS, HAS NO LEAKS, HAD THE TRANSMISSION REPLACED 5 YRS AGO THAN A YR LATER IT STOPPED UP SHIFTING, IT WILL ONLY GO ABOUT 35 MPH SO HAD ANOTHER TRANSMISSION INSTALLED STILL WONT SHIFT WAS TOLD TO REPLACE SPEED SENSOR SO I DID THIS DID NOT FIX THE PROBLEM. I FOUND A BROKEN WIRE GOING TO THE BRAIN OF TRUCK WENT TO THE JUNK YARD AND GOT ANOTHER PLUG FOR THE COMPUTER ITS THE RED PLUG TO THE COMPUTER, BUT FOUND OUT THAT THERE IS ANOTHER WIRE WERE THE BROKEN WIRE WAS (BLACK WITH A WHITE STRIPE). I NEED YOUR HELP EVERYONE THAT I ASK ABOUT IT DOESNT SEEM TO KNOW. CAN YOU HELP ME PLEASE?
Do you
have the same problem?
Yes
No
Saturday, July 28th, 2007 AT 1:11 PM

12 Replies

Tiny
CLY
  • MEMBER
When you say that there are wires broken do you mean that they are broken at the connector for the computer? Your question is that you need to know where that wire goes in the connector?

Cly
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 5:29 AM
Tiny
JAY62078
  • MEMBER
No b/c i've got wires on the connector I bought from the junk yard. I'd like to know if this is the reason it's not shifting, also there was a bad ground in my truck and it looks like the repair shop but a thicker ga. Wire in its pace and ran the wire straight to where ever it goes I lose it half way through the wire loom. What I need to know is that if this controls the shifting or not? Or if there is anything else I need to do to get my truck up and running right?
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 1:38 PM
Tiny
CLY
  • MEMBER
I looked through the schematics and I dont see a wire that black with a white strip going to the trans at all.

Cly
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 2:50 PM
Tiny
JAY62078
  • MEMBER
So does this mean it could be a solenoid?
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 5:12 PM
Tiny
CLY
  • MEMBER
The truck will not shift up at all? It has first gear only?

Cly
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 5:52 PM
Tiny
JAY62078
  • MEMBER
Yes it only has first gear
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 6:09 PM
Tiny
CLY
  • MEMBER
Causes for first gear only are:

1st Gear Range Only - No Upshift Checks
Causes

Control Valve Body (60)
The 1-2 Shift valve is sticking

The spacer plate or gaskets are mispositioned or damaged

Case (103)
The case to valve body face is damaged or is not flat

Shift Solenoid Valves (366/368)
Stuck or damaged

Faulty electrical connection

2-4 Servo Assembly (13-28 )
The apply passage case is restricted or blocked

Nicks or burrs on the servo pin or on the pin bore in the case

Fourth servo piston is installed backwards

2-4 Band Assembly (602)
The 2-4 band is worn or damaged

The band anchor pin is not engaged

This is straight out of the manual. I would probably have to suggest that you take it in and have diagnostics ran. It is very unlikely that it will be a problem that can be pin-pointed without having the truck in front of me.

Sorry I couldn't be more help.

Cly
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 6:52 PM
Tiny
JAY62078
  • MEMBER
Had diagnostics done, and its not reading the transmission
Was this
answer
helpful?
Yes
No
Monday, July 30th, 2007 AT 5:09 PM
Tiny
CLY
  • MEMBER
If you take away all voltage(unplug the connector to the trans) the trans should be in 3rd gear. That is the part that is throwing me off. If you had a bad solenoid stuck on or off you would have at least two gears(1 & 4 or 2 & 3) Where is this wire (Blk/wht) coming from?

Cly
Was this
answer
helpful?
Yes
No
Monday, July 30th, 2007 AT 7:25 PM
Tiny
JAY62078
  • MEMBER
No sure were its coming from just know it connects to the red plug that connects to the computer
Was this
answer
helpful?
Yes
No
Monday, July 30th, 2007 AT 8:31 PM
Tiny
CLY
  • MEMBER
Ok.I did some searching and found the blk/wht wire from the red ecm plug. It comes from the ecm and is a ground wire that goes to the back of the left cylinder head. I would also check the ground on the back of the rightside cylinder head as well.

Cly
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2007 AT 3:29 PM
Tiny
JAY62078
  • MEMBER
Thanks
Was this
answer
helpful?
Yes
No
Thursday, August 2nd, 2007 AT 2:29 PM

Please login or register to post a reply.

Recommended Guides